summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--[-rwxr-xr-x]PKGBUILD25
2 files changed, 18 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f1866014509..3304951e0902 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = sparta
- pkgdesc = Is a python GUI application which simplifies network infrastructure penetration testing by aiding the penetration tester in the scanning and enumeration phase.
+ pkgdesc = Python GUI application which simplifies network infrastructure penetration testing.
pkgver = 1.0.1
pkgrel = 1
- url = http://sparta.secforce.com/
+ url = https://sparta.secforce.com/
arch = any
license = GPL2
depends = python2
@@ -10,12 +10,13 @@ pkgbase = sparta
depends = python2-elixir
depends = python2-lxml
optdepends = cutycapt: take screenshots of websites
- provides = sparta
- conflicts = sparta
- source = https://github.com/SECFORCE/sparta/archive/v1.0.1.tar.gz
+ optdepends = nmap: Nmap support
+ optdepends = hydra: bruteforce
+ optdepends = nikto: information gathering
+ source = sparta-1.0.1.tar.gz::https://github.com/SECFORCE/sparta/archive/v1.0.1.tar.gz
source = sparta_launcher
- md5sums = 710f86f0037e735e44a3dcd01db96af6
- md5sums = 58f2181719cf57f9d5df3da9c8145c57
+ sha256sums = 14aba154a94f2f31929087849c0dde44cdb59c337a8ecf2b0cecbae71690738f
+ sha256sums = b4ff80756b302f76f5d20c9f92de42382d396ae29abf83e1158e18cbe493e31b
pkgname = sparta
diff --git a/PKGBUILD b/PKGBUILD
index 7d547c5e07d9..0b256473ba3d 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,21 @@
# Maintainer: FFY00 <filipe.lains@gmail.com>
# Contributor: Cyberpunk <aur_linuxero@outlook.com>
-
pkgname=sparta
pkgver=1.0.1
pkgrel=1
-pkgdesc="Is a python GUI application which simplifies network infrastructure penetration testing by aiding the penetration tester in the scanning and enumeration phase."
+pkgdesc="Python GUI application which simplifies network infrastructure penetration testing."
arch=('any')
-url="http://sparta.secforce.com/"
+url="https://sparta.secforce.com/"
license=('GPL2')
depends=('python2' 'python2-pyqt4<=4.10.0' 'python2-elixir' 'python2-lxml')
-optdepends=('cutycapt: take screenshots of websites')
-makedeps=('nmap' 'hydra' 'nikto')
-provides=('sparta')
-conflicts=('sparta')
-source=(
- "https://github.com/SECFORCE/sparta/archive/v${pkgver}.tar.gz"
- 'sparta_launcher'
-)
-md5sums=(
- '710f86f0037e735e44a3dcd01db96af6'
- '58f2181719cf57f9d5df3da9c8145c57'
-)
+optdepends=('cutycapt: take screenshots of websites'
+ 'nmap: Nmap support'
+ 'hydra: bruteforce'
+ 'nikto: information gathering')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/SECFORCE/sparta/archive/v${pkgver}.tar.gz"
+ 'sparta_launcher')
+sha256sums=('14aba154a94f2f31929087849c0dde44cdb59c337a8ecf2b0cecbae71690738f'
+ 'b4ff80756b302f76f5d20c9f92de42382d396ae29abf83e1158e18cbe493e31b')
package() {
install -dm 755 "$pkgdir"/usr/bin/