summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD63
-rw-r--r--speed-dreams.desktop (renamed from speed-dreams-svn.desktop)2
3 files changed, 55 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 902859295f84..2bfe9dfcba3e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = speed-dreams-svn
pkgdesc = Speed Dreams is a fork of TORCS which aims to implement exciting new features, improving visual and physics realism.
pkgver = svn
- pkgrel = 1
- url = http://speed-dreams.sourceforge.net/
+ pkgrel = 2
+ url = http://www.speed-dreams.net/
arch = i686
arch = x86_64
license = GPL2
@@ -19,10 +19,15 @@ pkgbase = speed-dreams-svn
depends = zlib
depends = enet
depends = openscenegraph
- source = speed-dreams-svn.desktop
- source = speed-dreams-svn::svn+https://svn.code.sf.net/p/speed-dreams/code/trunk
- md5sums = 9a0a63c897668ee18bcd6c5d65fe2111
+ depends = sdl2_mixer
+ depends = jre
+ depends = jdk
+ provides = speed-dreams
+ conflicts = speed-dreams
+ conflicts = speed-dreams-git
+ source = speed-dreams.desktop
+ source = speed-dreams::svn+https://svn.code.sf.net/p/speed-dreams/code/trunk
+ md5sums = ae5f7bd147981323414e1c5b859cdd83
md5sums = SKIP
pkgname = speed-dreams-svn
-
diff --git a/PKGBUILD b/PKGBUILD
index 4894f51bfa56..3479dd6c57e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,73 @@
-# Maintainer: Tim Wanders <tim241 at mailbox dot org>
-# Contributor: Adrián Chaves Fernández, aka Gallaecio <adriyetichaves@gmail.com>
+# Mantainer: Leillo1975 <leillo1975 at gmail dot com>
+# Contributor: Aleksandr <contact at via dot aur>
+# Contributor: Tim Wanders <tim241 at mailbox dot org>
+# Contributor: Adrián Chaves Fernández, aka Gallaecio <adriyetichaves at gmail dot com>
pkgname=speed-dreams-svn
pkgver=svn
-pkgrel=1
+pkgrel=2
pkgdesc="Speed Dreams is a fork of TORCS which aims to implement exciting new features, improving visual and physics realism."
arch=('i686' 'x86_64')
-url="http://speed-dreams.sourceforge.net/"
+url="https://www.speed-dreams.net"
license=('GPL2')
-depends=('freealut' 'freeglut' 'libpng' 'libxi' 'libxmu' 'libxrandr' 'plib>=1.8.3' 'libjpeg' 'zlib' 'enet' 'openscenegraph')
-
+depends=('freealut' 'freeglut' 'libpng' 'libxi' 'libxmu' 'libxrandr' 'plib>=1.8.3' 'libjpeg' 'zlib' 'enet' 'openscenegraph' 'sdl2_mixer' 'jre' 'jdk')
makedepends=('cmake' 'svn')
+provides=("${pkgname%-svn}")
+conflicts=("${pkgname%-svn}" 'speed-dreams-git')
+source=("${pkgname%-svn}.desktop"
+ "${pkgname%-svn}::svn+https://svn.code.sf.net/p/speed-dreams/code/trunk")
+
+md5sums=('ae5f7bd147981323414e1c5b859cdd83'
+ 'SKIP')
-source=("${pkgname}.desktop"
- "$pkgname::svn+https://svn.code.sf.net/p/speed-dreams/code/trunk")
+pkgver() {
+ cd "$srcdir/${pkgname%-svn}"
-md5sums=("9a0a63c897668ee18bcd6c5d65fe2111"
- "SKIP")
+ printf "r%s" "$(svnversion | tr -d 'A-z')"
+}
prepare() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/${pkgname%-svn}"
- if [ -d build ]
- then
+ if [ -d build ]; then
rm -rf build
fi
-
mkdir build
cd build
- cmake ../ -Wno-dev
+ cmake -Wno-dev \
+ -D CMAKE_PREFIX_PATH:STRING=/usr \
+ -D CMAKE_BUILD_TYPE:STRING=MinSizeRel \
+ -D CMAKE_INSTALL_PREFIX:PATH=/usr \
+ -D SD_LOCALDIR:STRING=~/.config/speed-dreams-2 \
+ -D SD_BINDIR:STRING=/usr/games \
+ -D SD_LIBDIR:STRING=/usr/lib \
+ -D SD_DATADIR:STRING=/usr/share/games/speed-dreams-2 \
+ -D OPTION_TRACE_LEVEL:STRING=2 \
+ ../
}
build() {
- cd "$srcdir/$pkgname/build"
+ cd "$srcdir/${pkgname%-svn}/build"
make
}
package() {
- cd "$srcdir/$pkgname/build"
+ cd "$srcdir/${pkgname%-svn}/build"
make DESTDIR="$pkgdir" install
- install -D -m644 "${pkgdir}/usr/local/share/games/speed-dreams-2/data/icons/icon.png" \
+ install -D -m644 "${pkgdir}/usr/share/games/speed-dreams-2/data/icons/icon.png" \
"${pkgdir}/usr/share/pixmaps/speed-dreams-2.png"
- install -D -m644 "$srcdir/${pkgname}.desktop" \
- "${pkgdir}/usr/share/applications/speed-dreams-svn.desktop"
+ install -D -m644 "$srcdir/${pkgname%-svn}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname%-svn}.desktop"
+ install -d -m0755 "${pkgdir}/usr/bin"
+
+ cd "${pkgdir}"/usr/games/
+ for i in * ; do
+ cd "${pkgdir}"/usr/bin/
+ ln -s /usr/games/$i .
+ done
}
+
diff --git a/speed-dreams-svn.desktop b/speed-dreams.desktop
index b498464b18fc..2e0e379417f5 100644
--- a/speed-dreams-svn.desktop
+++ b/speed-dreams.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=Speed Dreams 2 (SVN)
Comment=The Open Racing Car Simulator Fork (SVN version)
-Exec=/usr/local/games/speed-dreams-2
+Exec=/usr/bin/speed-dreams-2
Icon=speed-dreams-2.png
Terminal=false
Type=Application