summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD21
-rwxr-xr-xupdate_version.sh21
4 files changed, 49 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07efc73fb35b..2316782dc9fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,22 @@
pkgbase = speedify
pkgdesc = Use multiple internet connections in parallel
- pkgver = 9.8.0.8512
- pkgrel = 2
+ pkgver = 14.7.0.11802
+ pkgrel = 0
url = https://speedify.com/
arch = x86_64
arch = aarch64
arch = armv7h
- license = UNKNOWN
- source_x86_64 = http://apt.connectify.me/pool/main/s/speedify/speedify_9.8.0-8512_amd64.deb
- md5sums_x86_64 = 3c3178d7eee99e641de9d41fc7b95dca
- source_aarch64 = http://apt.connectify.me/pool/main/s/speedify/speedify_9.8.0-8512_arm64.deb
- md5sums_aarch64 = 35ccf06e835a10350fe70671a6439ca2
- source_armv7h = http://apt.connectify.me/pool/main/s/speedify/speedify_9.8.0-8512_armhf.deb
- md5sums_armv7h = 21498b3c58a5fab3344dca2a42b3e228
+ license = unknown
+ depends = lsof
+ depends = net-tools
+ provides = speedify
+ source_x86_64 = http://apt.connectify.me/pool/main/s/speedify/speedify_14.7.0-11802_amd64.deb
+ md5sums_x86_64 = 8fb6076b8296ec571200599a30e1997b
+ sha256sums_x86_64 = 92cc5de82bfa713f013ef7d3c1dd94e9090559b401df275f0a1e7c91fec1f8d4
+ sha512sums_x86_64 = e74d2168c2aa2bc6610ad05df3aae8a00a146dd1d433ecd0033cda0c5b39fb1be6583d318623f06ab79dcae7b11cc72fbd58886f6cfce71e07f9a6c4b12b82b9
+ source_aarch64 = http://apt.connectify.me/pool/main/s/speedify/speedify_14.7.0-11802_arm64.deb
+ md5sums_aarch64 = SKIP
+ source_armv7h = http://apt.connectify.me/pool/main/s/speedify/speedify_14.7.0-11802_armhf.deb
+ md5sums_armv7h = SKIP
pkgname = speedify
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..fbed214c2534
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+speedify* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 56cedebecc3e..7e29031d6d75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,17 @@
+# Maintainer: LoupZeur <loup@loupzeur.net>
# Maintainer: Semyon Maryasin <simeon@maryasin.name>
pkgname=speedify
-_pkgver=9.8.0-8512
+_pkgver=14.7.0-11802
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=0
pkgdesc="Use multiple internet connections in parallel"
arch=('x86_64' 'aarch64' 'armv7h')
url="https://speedify.com/"
-license=(UNKNOWN)
+license=(unknown)
groups=()
-depends=()
+depends=( lsof net-tools )
makedepends=()
-provides=()
-conflicts=()
-replaces=()
+provides=(speedify)
backup=()
options=()
install=
@@ -21,9 +20,11 @@ source_x86_64=(http://apt.connectify.me/pool/main/${pkgname:0:1}/${pkgname}/${pk
source_aarch64=(http://apt.connectify.me/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${_pkgver}_arm64.deb)
source_armv7h=(http://apt.connectify.me/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${_pkgver}_armhf.deb)
# TODO: i386 is also supported
-md5sums_x86_64=('3c3178d7eee99e641de9d41fc7b95dca')
-md5sums_aarch64=('35ccf06e835a10350fe70671a6439ca2')
-md5sums_armv7h=('21498b3c58a5fab3344dca2a42b3e228')
+md5sums_x86_64=('8fb6076b8296ec571200599a30e1997b')
+sha256sums_x86_64=('92cc5de82bfa713f013ef7d3c1dd94e9090559b401df275f0a1e7c91fec1f8d4')
+sha512sums_x86_64=('e74d2168c2aa2bc6610ad05df3aae8a00a146dd1d433ecd0033cda0c5b39fb1be6583d318623f06ab79dcae7b11cc72fbd58886f6cfce71e07f9a6c4b12b82b9')
+md5sums_aarch64=('SKIP')
+md5sums_armv7h=('SKIP')
prepare() {
cd "$srcdir"
diff --git a/update_version.sh b/update_version.sh
new file mode 100755
index 000000000000..add7850a1746
--- /dev/null
+++ b/update_version.sh
@@ -0,0 +1,21 @@
+PKG=`curl https://apt.connectify.me/dists/speedify/main/binary-amd64/Packages`
+NVERSION=`echo "$PKG"|grep Version|head -1|cut -d" " -f2`
+CVERSION=`cat PKGBUILD |grep _pkgver=|cut -d= -f2`
+MD5=$(echo "$PKG"|grep MD5sum|head -1|cut -d" " -f2)
+SHA5=$(echo "$PKG"|grep SHA512|head -1|cut -d" " -f2)
+SHA2=$(echo "$PKG"|grep SHA256|head -1|cut -d" " -f2)
+
+echo "Versions: '$NVERSION' '$CVERSION'"
+if [ $NVERSION != $CVERSION ]; then
+ echo "Updating ..."
+ sed -i "s/$CVERSION/$NVERSION/g" PKGBUILD
+ sed -i "s/\(md5sums_x86_64=\).*/\1('$MD5')/" PKGBUILD
+ sed -i "s/\(sha512sums_x86_64=\).*/\1('$SHA5')/" PKGBUILD
+ sed -i "s/\(sha256sums_x86_64=\).*/\1('$SHA2')/" PKGBUILD
+ sed -i "s/pkgrel=.*/pkgrel=0/" PKGBUILD
+ #to see if it build
+ makepkg
+ makepkg --printsrcinfo > .SRCINFO
+ git commit -am "New version $NVERSION"
+ git push
+fi