summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO2
-rwxr-xr-xPKGBUILD17
2 files changed, 10 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ff38524931c..20900ef34b45 100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sph-web-publish-git
pkgdesc = static site generator
- pkgver = 30
+ pkgver = 42
pkgrel = 1
url = http://sph.mn
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 020dabb9d999..8e7302572d4f 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,6 @@
-pkgname=sph-web-publish-git
-pkgver=30
+_name=sph-web-publish
+pkgname=$_name-git
+pkgver=42
pkgrel=1
pkgdesc="static site generator"
arch=(any)
@@ -7,18 +8,18 @@ license=(gpl3+)
makedepends=(git)
depends=(guile guile-commonmark sph-lib)
optdepends=(rsync graphicsmagick)
-provides=(sph-web-publish)
-conflicts=(sph-web-publish)
-source=("git://git.sph.mn/sph-web-publish")
+provides=($_name)
+conflicts=($_name)
+source=("git://git.sph.mn/$_name")
url="http://sph.mn"
md5sums=(SKIP)
pkgver() {
- cd sph-web-publish
+ cd $_name
git rev-list --count HEAD
}
package() {
- cd sph-web-publish
- ./exe/install "${pkgdir}"
+ cd $_name
+ ./exe/install "$pkgdir"
} \ No newline at end of file