summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
-rw-r--r--spindown.service9
-rw-r--r--spindown.tmpfiles1
4 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..961c44ca6e21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = spindown
+ pkgdesc = Daemon that spins down idle disks
+ pkgver = 0.4.0
+ pkgrel = 6
+ url = http://code.google.com/p/spindown/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = sg3_utils
+ backup = etc/spindown.conf
+ source = http://spindown.googlecode.com/files/spindown-0.4.0.tar.gz
+ source = spindown.service
+ source = spindown.tmpfiles
+ md5sums = 9ec7400cdd6540a404039492291f41cf
+ md5sums = 3dbf50c10ab13964ee7b044ed9006165
+ md5sums = a0b4ea847c00b8f363a521039c0f86cd
+
+pkgname = spindown
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..34e74bd03559
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Tom < reztho at archlinux dot us >
+pkgname=spindown
+pkgver=0.4.0
+pkgrel=6
+pkgdesc="Daemon that spins down idle disks"
+arch=('i686' 'x86_64')
+url="http://code.google.com/p/spindown/"
+license=('GPL3')
+depends=('sg3_utils')
+backup=('etc/spindown.conf')
+source=("http://spindown.googlecode.com/files/${pkgname}-${pkgver}.tar.gz"
+ 'spindown.service'
+ 'spindown.tmpfiles')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ make SBINDIR=${pkgdir}/usr/bin DESTDIR=${pkgdir} install
+ rm -rf ${pkgdir}/etc/*
+ install -m 644 ${srcdir}/${pkgname}-${pkgver}/spindown.conf.example \
+ ${pkgdir}/etc/spindown.conf
+ install -dm 755 ${pkgdir}/usr/lib/systemd/system/
+ install -m 644 ${srcdir}/spindown.service ${pkgdir}/usr/lib/systemd/system/spindown.service
+ install -dm 755 ${pkgdir}/usr/lib/tmpfiles.d/
+ install -m 644 ${srcdir}/spindown.tmpfiles ${pkgdir}/usr/lib/tmpfiles.d/spindown.conf
+}
+
+md5sums=('9ec7400cdd6540a404039492291f41cf'
+ '3dbf50c10ab13964ee7b044ed9006165'
+ 'a0b4ea847c00b8f363a521039c0f86cd')
diff --git a/spindown.service b/spindown.service
new file mode 100644
index 000000000000..9145ab9e41c5
--- /dev/null
+++ b/spindown.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Spindown Daemon
+
+[Service]
+ExecStart=/usr/bin/spindownd -d -f /run/spindown/spindownd.fifo -c /etc/spindown.conf -p /run/spindown/spindown.pid
+PIDFile=/run/spindown/spindown.pid
+
+[Install]
+WantedBy=multi-user.target
diff --git a/spindown.tmpfiles b/spindown.tmpfiles
new file mode 100644
index 000000000000..37cb982427a6
--- /dev/null
+++ b/spindown.tmpfiles
@@ -0,0 +1 @@
+d /run/spindown 0755 root root - -