summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--httpd-spip.conf4
-rw-r--r--mes_options.php2
4 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 57451d25006e..71a7155a1a8f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = spip
pkgdesc = A publishing system for the Internet in which great importance is attached to collaborative working, to multilingual environments, and to simplicity of use for web authors.
pkgver = 3.0.16
- pkgrel = 1
+ pkgrel = 2
url = http://www.spip.net/
arch = x86
arch = x86_64
@@ -12,8 +12,8 @@ pkgbase = spip
source = httpd-spip.conf
source = mes_options.php
sha256sums = 42e9cdb6a6d2a38ff2ad22606a264d88545e2c23969bca8d2f8ef72ed450aab1
- sha256sums = 0dfd06634f748eba922f24a99f42253663fa2c3939f727e073a052dc51e49764
- sha256sums = 1b1ac9dcd33e5c6605ed8319dfca5111bea8a53e9822db3219b60b870c13d5f8
+ sha256sums = 18c625bf2192ceb7647617593285c9fbfc110197c0179ac8ae4bc70c414b9582
+ sha256sums = 9c2eed4d009faef9128ec60135b4ff03c3c2d09387a7ac7f4887748f0d85ce75
pkgname = spip
diff --git a/PKGBUILD b/PKGBUILD
index dc3d263c7d62..7a676c3ddd3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=spip
pkgver=3.0.16
-pkgrel=1
+pkgrel=2
pkgdesc="A publishing system for the Internet in which great importance is attached to collaborative working, to multilingual environments, and to simplicity of use for web authors."
arch=('x86' 'x86_64')
url="http://www.spip.net/"
@@ -13,8 +13,8 @@ source=("http://files.spip.org/spip/archives/SPIP-v${pkgver}.zip"
"mes_options.php")
options=(!strip)
sha256sums=('42e9cdb6a6d2a38ff2ad22606a264d88545e2c23969bca8d2f8ef72ed450aab1'
- '0dfd06634f748eba922f24a99f42253663fa2c3939f727e073a052dc51e49764'
- '1b1ac9dcd33e5c6605ed8319dfca5111bea8a53e9822db3219b60b870c13d5f8')
+ '18c625bf2192ceb7647617593285c9fbfc110197c0179ac8ae4bc70c414b9582'
+ '9c2eed4d009faef9128ec60135b4ff03c3c2d09387a7ac7f4887748f0d85ce75')
package() {
install -d ${pkgdir}/usr/share/webapps/
@@ -30,8 +30,8 @@ package() {
install -m 644 ${srcdir}/mes_options.php ${pkgdir}/etc/webapps/${pkgname}/base
install -m 644 ${srcdir}/httpd-spip.conf ${pkgdir}/etc/webapps/${pkgname}/
- install -d ${pkgdir}/var/lib/${pkgname}
- ln -s /var/lib/${pkgname} ${pkgdir}/usr/share/webapps/${pkgname}/sites
- chown -R http:http ${pkgdir}/etc/webapps/${pkgname}/ ${pkgdir}/var/lib/${pkgname}
+ install -d ${pkgdir}/srv/${pkgname}
+ ln -s /srv/${pkgname} ${pkgdir}/usr/share/webapps/${pkgname}/sites
+ chown -R http:http ${pkgdir}/etc/webapps/${pkgname}/ ${pkgdir}/srv/${pkgname}
}
diff --git a/httpd-spip.conf b/httpd-spip.conf
index c9acc84d4b6e..12101322fc01 100644
--- a/httpd-spip.conf
+++ b/httpd-spip.conf
@@ -1,5 +1,5 @@
#This is an example apache file for system-located spip website. The database
-#and images will be located in /var/lib/spip/<name>, while config file will be in
+#and images will be located in /srv/spip/<name>, while config file will be in
#/etc/webapps/spip/<name>
# To setup the database go to http://spip.example.com/ecrire/
<VirtualHost *:80>
@@ -9,7 +9,7 @@
<Directory /usr/share/webapps/spip>
DirectoryIndex index.php index.htm index.html
Options Indexes FollowSymLinks MultiViews Includes
- php_value open_basedir /usr/share/webapps/:/usr/lib/:/etc/webapps/spip:/var/lib/spip/
+ php_value open_basedir /usr/share/webapps/:/usr/lib/:/etc/webapps/spip:/srv/spip/
AllowOverride All
Require all granted
#If you want to have subfolders like
diff --git a/mes_options.php b/mes_options.php
index 8d5ef786c2bc..db72597a4d5e 100644
--- a/mes_options.php
+++ b/mes_options.php
@@ -9,7 +9,7 @@ if ( preg_match(',^/([\.a-zA-Z0-9_-]+)/,', $_SERVER['REQUEST_URI'], $r)
$site = $_SERVER['HTTP_HOST'];
}
-// This is a symlink to /var/lib/spip/
+// This is a symlink to /srv/spip/
// Sites are of the form <host> or <host>__<folder> (cf. above)
$rep = 'sites/';
$path = _DIR_RACINE . $rep . $site . '/';