summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD58
-rw-r--r--spiral-knights.install24
3 files changed, 98 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8aa9ce14fcb9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sun Feb 21 21:09:48 UTC 2016
+pkgbase = spiral-knights
+ pkgdesc = The Spiral Knights have awoken on an alien world. Their equipment stores have been raided and their starship, The Skylark, will not recover from the crash. They must work together to survive on a journey that will take them to the very core of the world.
+ pkgver = 20140522
+ pkgrel = 1
+ url = http://spiralknights.com/
+ install = spiral-knights.install
+ arch = any
+ license = custom:Three Rings License
+ depends = java-runtime
+ source = http://download.threerings.net/spiral/client/spiral-install.bin
+ sha256sums = SKIP
+
+pkgname = spiral-knights
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..83448baf3239
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Contributor: hauzer <alokinpwn@gmail.com>
+# Previous Maintainer: Mineko
+# Previous Maintainer: Ben R <thebenj88 *AT* gmail *DOT* com>
+# Maintainer: maraku <maraku@gmx.com>
+
+pkgname=spiral-knights
+pkgver=20140522
+pkgrel=1
+pkgdesc="The Spiral Knights have awoken on an alien world. Their equipment stores have been raided and their starship, The Skylark, will not recover from the crash. They must work together to survive on a journey that will take them to the very core of the world."
+arch=('any')
+url="http://spiralknights.com/"
+license=('custom:Three Rings License')
+depends=('java-runtime')
+install="${pkgname}.install"
+source=("http://download.threerings.net/spiral/client/spiral-install.bin")
+sha256sums=('SKIP')
+
+build() {
+ chmod +x "${srcdir}/spiral-install.bin"
+ "${srcdir}/spiral-install.bin" --noexec --keep --nochown --target "${srcdir}/${pkgname}-${pkgver}"
+}
+
+package() {
+ cat > ${pkgname} << EOF
+ #!/bin/bash
+ /opt/${pkgname}/spiral
+EOF
+
+ cat > ${pkgname}.desktop << EOF
+ [Desktop Entry]
+ Type=Application
+ Version=1.0
+ Name=Spiral Knights
+ Icon=/opt/${pkgname}/icon_32.png
+ Exec=${pkgname}
+ Terminal=false
+ Categories=Game;Java;
+EOF
+
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/background.png" "${pkgdir}/opt/${pkgname}/background.png"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/desktop.png" "${pkgdir}/opt/${pkgname}/desktop.png"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/getdown-pro.jar" "${pkgdir}/opt/${pkgname}/getdown-pro.jar"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/getdown.txt" "${pkgdir}/opt/${pkgname}/getdown.txt"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/icon_128.png" "${pkgdir}/opt/${pkgname}/icon_128.png"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/icon_16.png" "${pkgdir}/opt/${pkgname}/icon_16.png"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/icon_32.png" "${pkgdir}/opt/${pkgname}/icon_32.png"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/license.txt" "${pkgdir}/opt/${pkgname}/license.txt"
+ install -D -m 644 "${srcdir}/${pkgname}-${pkgver}/progress.png" "${pkgdir}/opt/${pkgname}/progress.png"
+ install -D -m 755 "${srcdir}/${pkgname}-${pkgver}/spiral" "${pkgdir}/opt/${pkgname}/spiral"
+
+ install -D -m 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m 664 "${srcdir}/${pkgname}-${pkgver}/license.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ ln -s "${JAVA_HOME}/bin/java" "${pkgdir}/opt/${pkgname}/java"
+ chgrp games "${pkgdir}/opt/${pkgname}" && chmod 775 "${pkgdir}/opt/${pkgname}"
+}
+
diff --git a/spiral-knights.install b/spiral-knights.install
new file mode 100644
index 000000000000..38ee16c2962f
--- /dev/null
+++ b/spiral-knights.install
@@ -0,0 +1,24 @@
+pre_install() {
+cat > /dev/stdout <<EOF
+===============================================================================
+| |
+| If you're concerned about security, be advised. For this game to work, it's |
+| actual game files need to be downloaded after installing, thus write access |
+| to the installation directory is needed for the ordinary user. User has to |
+| be in the 'games' group. |
+| |
+===============================================================================
+EOF
+}
+
+post_remove() {
+cat > /dev/stdout <<EOF
+===============================================================================
+| |
+| Any downloaded game data may still be resident in the installation |
+| directory. |
+| |
+===============================================================================
+EOF
+}
+