summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO37
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD62
-rw-r--r--spl.install16
4 files changed, 119 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1456d6243a4c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,37 @@
+# Generated by mksrcinfo v8
+# Wed Dec 13 20:27:07 UTC 2017
+pkgbase = spl-linux-vfio
+ pkgver = 0.7.4.4.13.12.2
+ pkgrel = 1
+ url = http://zfsonlinux.org/
+ arch = x86_64
+ license = GPL
+ makedepends = linux-vfio-headers=4.13.12-2
+ makedepends = git
+ depends = spl-utils-common=0.7.4
+ depends = kmod
+ depends = linux-vfio=4.13.12-2
+ source = https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/spl-0.7.4.tar.gz
+ sha256sums = SKIP
+
+pkgname = spl-linux-vfio
+ pkgdesc = Solaris Porting Layer kernel modules.
+ install = spl.install
+ groups = archzfs-linux-vfio
+ provides = spl
+ conflicts = spl-linux-vfio-git
+ replaces = spl-git
+
+pkgname = spl-linux-vfio-headers
+ pkgdesc = Solaris Porting Layer kernel headers.
+ conflicts = spl-archiso-linux-headers
+ conflicts = spl-linux-hardened-headers
+ conflicts = spl-linux-hardened-git-headers
+ conflicts = spl-linux-lts-headers
+ conflicts = spl-linux-lts-git-headers
+ conflicts = spl-linux-headers
+ conflicts = spl-linux-git-headers
+ conflicts = spl-linux-vfio-git-headers
+ conflicts = spl-linux-zen-headers
+ conflicts = spl-linux-zen-git-headers
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..401b4e6c29d6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.tar.xz
+*.sig
+*.log
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b69e9c27c38d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
+#
+# This PKGBUILD was generated by the archzfs build scripts located at
+#
+# http://github.com/archzfs/archzfs
+#
+# ! WARNING !
+#
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-vfio packages will only work with the default linux-vfio package! To have a single PKGBUILD target many
+# kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+pkgbase="spl-linux-vfio"
+pkgname=("spl-linux-vfio" "spl-linux-vfio-headers")
+
+pkgver=0.7.4.4.13.12.2
+pkgrel=1
+makedepends=("linux-vfio-headers=4.13.12-2" "git")
+arch=("x86_64")
+url="http://zfsonlinux.org/"
+source=("https://github.com/zfsonlinux/zfs/releases/download/zfs-0.7.4/spl-0.7.4.tar.gz")
+sha256sums=("SKIP")
+license=("GPL")
+depends=("spl-utils-common=0.7.4" "kmod" "linux-vfio=4.13.12-2")
+
+build() {
+ cd "${srcdir}/spl-0.7.4"
+ ./autogen.sh
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin \
+ --with-linux=/usr/lib/modules/4.13.12-2-vfio/build \
+ --with-linux-obj=/usr/lib/modules/4.13.12-2-vfio/build \
+ --with-config=kernel
+ make
+}
+
+package_spl-linux-vfio() {
+ pkgdesc="Solaris Porting Layer kernel modules."
+ install=spl.install
+ provides=("spl")
+ groups=("archzfs-linux-vfio")
+ conflicts=('spl-linux-vfio-git')
+ replaces=("spl-git")
+ cd "${srcdir}/spl-0.7.4"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/lib" "${pkgdir}/usr/"
+ # Remove src dir
+ rm -r "${pkgdir}"/usr/src
+}
+
+package_spl-linux-vfio-headers() {
+ pkgdesc="Solaris Porting Layer kernel headers."
+ conflicts=('spl-archiso-linux-headers' 'spl-linux-hardened-headers' 'spl-linux-hardened-git-headers' 'spl-linux-lts-headers' 'spl-linux-lts-git-headers' 'spl-linux-headers' 'spl-linux-git-headers' 'spl-linux-vfio-git-headers' 'spl-linux-zen-headers' 'spl-linux-zen-git-headers' )
+ cd "${srcdir}/spl-0.7.4"
+ make DESTDIR="${pkgdir}" install
+ rm -r "${pkgdir}/lib"
+ # Remove reference to ${srcdir}
+ sed -i "s+${srcdir}++" ${pkgdir}/usr/src/spl-*/4.13.12-2-vfio/Module.symvers
+}
diff --git a/spl.install b/spl.install
new file mode 100644
index 000000000000..d5318b9c99e3
--- /dev/null
+++ b/spl.install
@@ -0,0 +1,16 @@
+post_install() {
+ run_depmod
+}
+
+post_remove() {
+ run_depmod
+}
+
+post_upgrade() {
+ run_depmod
+}
+
+run_depmod() {
+ echo ">>> Updating SPL module dependencies"
+ depmod -a 4.13.12-2-vfio
+}