summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD42
2 files changed, 26 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index df564e551d43..d249a23a95dd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
# Generated by mksrcinfo v8
-# Sat Apr 16 20:25:31 UTC 2016
-pkgbase = spl-utils-lts
+# Fri Apr 22 02:15:24 UTC 2016
+pkgbase = spl-utils-linux-lts
pkgdesc = Solaris Porting Layer kernel module support files.
- pkgver = 0.6.5.6_4.4.7_1
+ pkgver = 0.6.5.6_4.4.8_1
pkgrel = 1
url = http://zfsonlinux.org/
- arch = i686
arch = x86_64
- groups = archzfs-lts
+ groups = archzfs-linux-lts
license = GPL
- provides = spl-utils
- conflicts = spl-utils
- conflicts = spl-utils-git
+ provides = spl-utils-linux-lts
source = http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/spl-0.6.5.6.tar.gz
source = spl-utils.hostid
sha256sums = 167595fe76eb5497c3a1ffe396b6300155d0cbe46d06824a710099ca1ae1b8bd
sha256sums = ad95131bc0b799c0b1af477fb14fcf26a6a9f76079e48bf090acb7e8367bfd0e
-pkgname = spl-utils-lts
+pkgname = spl-utils-linux-lts
diff --git a/PKGBUILD b/PKGBUILD
index 1f6637ff9863..61dadcb113cf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,44 @@
# Maintainer: Jesus Alvarez <jeezusjr at gmail dot com>
-# Contributor: Kyle Fuller <inbox at kylefuller dot co dot uk>
#
# This PKGBUILD was generated by the archzfs build scripts located at
#
-# http://github.com/demizer/archzfs
+# http://github.com/archzfs/archzfs
#
-# The build script generates and updates the pkgver and _kernel* variables.
+# ! WARNING !
#
-pkgname="spl-utils-lts"
-pkgver=0.6.5.6_4.4.7_1
+# The archzfs packages are kernel modules, so these PKGBUILDS will only work with the kernel package they target. In this
+# case, the archzfs-linux-lts packages will only work with the default linux-lts package! To have a single PKGBUILD target
+# many kernels would make for a cluttered PKGBUILD!
+#
+# If you have a custom kernel, you will need to change things in the PKGBUILDS. If you would like to have AUR or archzfs repo
+# packages for your favorite kernel package built using the archzfs build tools, submit a request in the Issue tracker on the
+# archzfs github page.
+#
+#
+pkgname="spl-utils-linux-lts"
+pkgver=0.6.5.6_4.4.8_1
pkgrel=1
pkgdesc="Solaris Porting Layer kernel module support files."
-arch=("i686" "x86_64")
+arch=("x86_64")
url="http://zfsonlinux.org/"
source=("http://archive.zfsonlinux.org/downloads/zfsonlinux/spl/spl-0.6.5.6.tar.gz"
"spl-utils.hostid")
-groups=("archzfs-lts")
+sha256sums=("167595fe76eb5497c3a1ffe396b6300155d0cbe46d06824a710099ca1ae1b8bd"
+ "ad95131bc0b799c0b1af477fb14fcf26a6a9f76079e48bf090acb7e8367bfd0e")
+groups=("archzfs-linux-lts")
license=("GPL")
-provides=("spl-utils")
-conflicts=("spl-utils" "spl-utils-git")
+provides=("spl-utils-linux-lts")
+
build() {
cd "${srcdir}/spl-0.6.5.6"
./autogen.sh
-
- _at_enable=""
- [ "${CARCH}" == "i686" ] && _at_enable="--enable-atomic-spinlocks"
-
- ./configure --prefix=/usr \
- --libdir=/usr/lib \
- --sbindir=/usr/bin \
- --with-config=user \
- ${_at_enable}
-
+ ./configure --prefix=/usr --libdir=/usr/lib --sbindir=/usr/bin --with-config=user
make
}
package() {
cd "${srcdir}/spl-0.6.5.6"
make DESTDIR="${pkgdir}" install
-
install -D -m644 "${srcdir}"/spl-utils.hostid "${pkgdir}"/etc/hostid
}
-sha256sums=('167595fe76eb5497c3a1ffe396b6300155d0cbe46d06824a710099ca1ae1b8bd'
- 'ad95131bc0b799c0b1af477fb14fcf26a6a9f76079e48bf090acb7e8367bfd0e')