summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 70e8a35c70ba..7ca9f065f3c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,3 @@
-# Generated by mksrcinfo v8
-# Wed Nov 14 06:20:10 UTC 2018
pkgbase = spotify-adkiller-git
pkgdesc = Your Party with Spotify - without ads!
pkgver = r177.2dabf81
diff --git a/PKGBUILD b/PKGBUILD
index 5f0415424c89..7aba2c4014fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -21,9 +21,15 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd ${url##*/}
+ sed -i 's/.sh//' spotify-wrapper.sh
+}
+
package() {
cd ${url##*/}
- install -Dt "$pkgdir"/usr/bin ${pkgname%-*}.sh spotify-wrapper.sh
+ install -D ${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}
+ install -D spotify-wrapper.sh "$pkgdir"/usr/bin/spotify-wrapper
install -Dm644 -t "$pkgdir"/usr/share/applications 'Spotify (AdKiller).desktop'
}