summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD38
2 files changed, 36 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ccf4e3c6e4f9..5db651a85442 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,22 @@
# Generated by mksrcinfo v8
-# Sat May 28 04:21:06 UTC 2016
-pkgbase = spotify-adkiller
- pkgdesc = Your Party with Spotify - but without ads!
- pkgver = 10
- pkgrel = 2
- epoch = 0
+# Wed Nov 9 22:13:59 UTC 2016
+pkgbase = spotify-adkiller-git
+ pkgdesc = Your Party with Spotify - without ads!
+ pkgver = r155.1fa0ff9
+ pkgrel = 1
url = https://github.com/SecUpwN/Spotify-AdKiller
arch = any
license = GPL3
makedepends = git
- depends = xorg-xprop
- depends = libpulse
depends = libnotify
depends = pulseaudio
+ depends = spotify
depends = xdotool
- source = spotify-adkiller::git+http://github.com/SecUpwN/Spotify-AdKiller#branch=master
- md5sums = SKIP
+ depends = xorg-xprop
+ provides = spotify-adkiller
+ conflicts = spotify-adkiller
+ source = https://github.com/SecUpwN/Spotify-AdKiller.git
+ sha512sums = SKIP
-pkgname = spotify-adkiller
+pkgname = spotify-adkiller-git
diff --git a/PKGBUILD b/PKGBUILD
index 30a7a7d1310c..20bf69290d61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
-# Maintainer: Sibren Vasse <arch @ sibrenvasse dot nl>
+# Maintainer: Daniel M. Capella <polyzen@archlinux.info>
+# Contributor: Sibren Vasse <arch @ sibrenvasse dot nl>
# Contributor: Preston Carpenter <APragmaticPlace@gmail.com>
-pkgname=spotify-adkiller
-source=("spotify-adkiller::git+http://github.com/SecUpwN/Spotify-AdKiller#branch=master")
-url="https://github.com/SecUpwN/Spotify-AdKiller"
-pkgver=10
-pkgrel=2
-epoch=0
-pkgdesc="Your Party with Spotify - but without ads!"
+pkgname=spotify-adkiller-git
+pkgver=r155.1fa0ff9
+pkgrel=1
+pkgdesc='Your Party with Spotify - without ads!'
arch=('any')
-makedepends=('git')
+url=https://github.com/SecUpwN/Spotify-AdKiller
license=('GPL3')
-depends=("xorg-xprop" "libpulse" "libnotify" "pulseaudio" "xdotool")
-md5sums=('SKIP')
+depends=('libnotify' 'pulseaudio' 'spotify' 'xdotool' 'xorg-xprop')
+makedepends=('git')
+provides=("${pkgname%-*}")
+conflicts=("${pkgname%-*}")
+source=("$url.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd ${pkgname%-*}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- install -Dm755 "$srcdir"/"$pkgname"/spotify-adkiller.sh "$pkgdir"/usr/bin/spotify-adkiller.sh
- install -Dm755 "$srcdir"/"$pkgname"/spotify-wrapper.sh "$pkgdir"/usr/bin/spotify-wrapper.sh
- install -Dm644 "$srcdir"/"$pkgname"/"Spotify (AdKiller).desktop" "$pkgdir"/usr/share/applications/"Spotify (AdKiller).desktop"
+ cd ${pkgname%-*}
+ install -Dm755 ${pkgname%-*}.sh "$pkgdir"/usr/bin/${pkgname%-*}.sh
+ install -Dm755 spotify-wrapper.sh "$pkgdir"/usr/bin/spotify-wrapper.sh
+ install -Dm644 'Spotify (AdKiller).desktop' "$pkgdir"/usr/share/applications/'Spotify (AdKiller).desktop'
}
+
+# vim:set ts=2 sw=2 et: