summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..78bc6e81fb3b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = spotify-adkiller
+ pkgdesc = Your Party with Spotify - but without ads!
+ pkgver = 10
+ pkgrel = 1
+ epoch = 0
+ url = https://github.com/SecUpwN/Spotify-AdKiller
+ arch = any
+ license = GPL3
+ depends = xorg-xprop
+ depends = libpulse
+ depends = libnotify
+ source = spotify-adkiller::git+http://github.com/SecUpwN/Spotify-AdKiller#branch=master
+ md5sums = SKIP
+
+pkgname = spotify-adkiller
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..17f0f57e82c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Sibren Vasse <arch @ sibrenvasse dot nl>
+# Contributor: Preston Carpenter <APragmaticPlace@gmail.com>
+
+pkgname=spotify-adkiller
+source=("spotify-adkiller::git+http://github.com/SecUpwN/Spotify-AdKiller#branch=master")
+url="https://github.com/SecUpwN/Spotify-AdKiller"
+pkgver=10
+pkgrel=1
+epoch=0
+pkgdesc="Your Party with Spotify - but without ads!"
+arch=('any')
+license=('GPL3')
+depends=("xorg-xprop" "libpulse" "libnotify")
+md5sums=('SKIP')
+
+package() {
+ install -Dm755 "$srcdir"/"$pkgname"/spotify-adkiller.sh "$pkgdir"/usr/bin/spotify-adkiller.sh
+ install -Dm755 "$srcdir"/"$pkgname"/spotify-wrapper.sh "$pkgdir"/usr/bin/spotify-wrapper.sh
+ install -Dm644 "$srcdir"/"$pkgname"/"Spotify (AdKiller).desktop" "$pkgdir"/usr/share/applications/"Spotify (AdKiller).desktop"
+}