summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..309138451f05
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = spotify-now-git
+ pkgdesc = Get information on the current Spotify song
+ pkgver = 22.9443251
+ pkgrel = 1
+ url = https://github.com/getmicah/spotify-now
+ arch = any
+ license = MIT
+ makedepends = git
+ conflicts = spotify-now
+ source = git://github.com/getmicah/spotify-now.git
+ sha256sums = SKIP
+
+pkgname = spotify-now-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..777ba55fa08e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: graysky <graysky AT archlinux DOT us>
+# Contributer: Serge Ziryukin <ftrvxmtrx@gmail.com>
+pkgname=spotify-now-git
+_pkgname=spotify-now
+pkgver=22.9443251
+pkgrel=1
+pkgdesc="Get information on the current Spotify song"
+arch=('any')
+url="https://github.com/getmicah/spotify-now"
+license=('MIT')
+makedepends=('git')
+conflicts=('spotify-now')
+source=("git://github.com/getmicah/$_pkgname.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ echo "$(git rev-list --count HEAD).$(git describe --always)"
+}
+
+package () {
+ cd "$_pkgname"
+ install -Dm755 $_pkgname "$pkgdir/usr/bin/$_pkgname"
+}