summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rwxr-xr-xupdate.sh5
3 files changed, 9 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73f34dba180f..9cb4abd96bbe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = spotify-tui-bin
pkgdesc = Spotify client for the terminal written in Rust
- pkgver = 0.10.0
- pkgrel = 2
+ pkgver = 0.16.0
+ pkgrel = 1
url = https://github.com/Rigellute/spotify-tui
arch = x86_64
license = MIT
depends = openssl
depends = libxcb
provides = spotify-tui
- source = https://github.com/Rigellute/spotify-tui/releases/download/v0.10.0/spotify-tui-linux.tar.gz
- source = https://raw.githubusercontent.com/Rigellute/spotify-tui/v0.10.0/LICENSE
- sha256sums = 4fd5aca58b30766bc23fa0690652a683a9fb752a958267583a36d0c417328c67
+ source = https://github.com/Rigellute/spotify-tui/releases/download/v0.16.0/spotify-tui-linux.tar.gz
+ source = https://raw.githubusercontent.com/Rigellute/spotify-tui/v0.16.0/LICENSE
+ sha256sums = 9c368a1a48d52c7241102e7c6774e811b96dac70411db73bc301da57c9de6d5a
sha256sums = 76b2d30f74716c0cbd02e37868961dce2b52f65af6355864d010ee7e695d2b88
pkgname = spotify-tui-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3825e3df0fac..c7d64f0d5211 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Rodrigo Gryzinski <rogryza@gmail.com>
pkgname='spotify-tui-bin'
-pkgver=0.10.0
-pkgrel=2
+pkgver=0.16.0
+pkgrel=1
pkgdesc="Spotify client for the terminal written in Rust"
arch=('x86_64')
url='https://github.com/Rigellute/spotify-tui'
@@ -12,7 +12,7 @@ provides=('spotify-tui')
source=("$url/releases/download/v$pkgver/spotify-tui-linux.tar.gz"
"https://raw.githubusercontent.com/Rigellute/spotify-tui/v$pkgver/LICENSE")
-sha256sums=('4fd5aca58b30766bc23fa0690652a683a9fb752a958267583a36d0c417328c67'
+sha256sums=('9c368a1a48d52c7241102e7c6774e811b96dac70411db73bc301da57c9de6d5a'
'76b2d30f74716c0cbd02e37868961dce2b52f65af6355864d010ee7e695d2b88')
function package {
diff --git a/update.sh b/update.sh
index 97c5ffce1f74..382db339c5fe 100755
--- a/update.sh
+++ b/update.sh
@@ -3,7 +3,7 @@
set -e
echo "Fetching latest release..."
-LATEST=$(hub api repos/Rigellute/spotify-tui/releases/latest | jq '.tag_name' -r)
+LATEST=$(hub api repos/Rigellute/spotify-tui/releases/latest | jq '.tag_name' -r | cut -c 2-)
CURRENT=$(grep '^pkgver=' PKGBUILD | grep -oEi '[[:digit:]]+\.[[:digit:]]+\.[[:digit:]]+')
if [ "$CURRENT" = "$LATEST" ]; then
@@ -15,7 +15,4 @@ else
updpkgsums
makepkg --printsrcinfo > .SRCINFO
-
- git add PKGBUILD .SRCINFO
- git commit -m "Update to $LATEST"
fi