summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
-rw-r--r--spotifyd.service11
4 files changed, 22 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9b30c08d4244..c9d43b8e551e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,21 @@
-# Generated by mksrcinfo v8
-# Wed Jul 26 10:56:07 UTC 2017
pkgbase = spotifyd
pkgdesc = A spotify playing daemon
- pkgver = 0.1.1.1.g60f111f
+ pkgver = 0.1.1
pkgrel = 1
url = https://github.com/Spotifyd/spotifyd
arch = x86_64
arch = armv7h
+ arch = aarch64
+ license = GPL3
makedepends = git
makedepends = cargo
- depends = pulseaudio
depends = flac
depends = libogg
- depends = libpulse
depends = libsndfile
depends = libvorbis
conflicts = spotifyd-bin
- source = spotifyd::git+https://github.com/Spotifyd/spotifyd
- source = spotifyd.service
- sha256sums = SKIP
- sha256sums = 67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4
+ source = spotifyd-0.1.1.tar.gz::https://github.com/Spotifyd/spotifyd/archive/v0.1.1.tar.gz
+ sha256sums = 4a1590acaf7417271d32c49ee835d54404a7954c6f283846f4904658b05767a4
pkgname = spotifyd
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index f50ab4841090..a7f68428f896 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,26 @@
-# Maintainer: Alexander Schäferdiek <alexander@schaeferdiek.eu>
-# Maintainer: Florian Klink <flokli@flokli.de>
+# Maintainer: Bert Peters <bert@bertptrs.nl>
+# Contributor: Alexander Schäferdiek <alexander@schaeferdiek.eu>
+# Contributor: Florian Klink <flokli@flokli.de>
pkgname=spotifyd
-pkgver=0.1.1.1.g60f111f
+pkgver=0.1.1
pkgrel=1
-arch=('x86_64' 'armv7h')
-depends=('pulseaudio' 'flac' 'libogg' 'libpulse' 'libsndfile' 'libvorbis')
+arch=('x86_64' 'armv7h' 'aarch64')
+license=('GPL3')
+depends=('flac' 'libogg' 'libsndfile' 'libvorbis')
makedepends=('git' 'cargo')
conflicts=('spotifyd-bin')
pkgdesc="A spotify playing daemon"
url="https://github.com/Spotifyd/spotifyd"
-source=("spotifyd::git+https://github.com/Spotifyd/spotifyd" "spotifyd.service")
-sha256sums=('SKIP'
- '67bce68cfad74bfccad4b471045d3c5d5fb0f693545f3ef12511d171ea41a5e4')
-pkgver() {
- cd $srcdir/spotifyd;
- git describe --tags --match 'v*' | sed 's/^v//;s/-/./g'
-}
+source=("spotifyd-$pkgver.tar.gz::https://github.com/Spotifyd/spotifyd/archive/v$pkgver.tar.gz")
+sha256sums=('4a1590acaf7417271d32c49ee835d54404a7954c6f283846f4904658b05767a4')
build() {
- cd $srcdir/spotifyd;
- cargo build --release --features "pulseaudio_backend"
+ cd "$srcdir/spotifyd-$pkgver"
+ cargo build --release
}
package() {
- install -D -m 755 $srcdir/spotifyd/target/release/spotifyd "${pkgdir}/usr/bin/spotifyd"
- install -D -m 644 "${srcdir}/spotifyd.service" "${pkgdir}/usr/lib/systemd/user/spotifyd.service"
+ install -D -m 755 "$srcdir/spotifyd-$pkgver/target/release/spotifyd" "${pkgdir}/usr/bin/spotifyd"
+ install -D -m 644 "$srcdir/spotifyd-$pkgver/contrib/spotifyd.service" "${pkgdir}/usr/lib/systemd/user/spotifyd.service"
}
diff --git a/spotifyd.service b/spotifyd.service
deleted file mode 100644
index df35ce64801d..000000000000
--- a/spotifyd.service
+++ /dev/null
@@ -1,11 +0,0 @@
-[Unit]
-Description=A spotify playing daemon
-Documentation=https://github.com/Spotifyd/spotifyd
-
-[Service]
-ExecStart=/usr/bin/spotifyd --no-daemon
-Restart=always
-RestartSec=12
-
-[Install]
-WantedBy=default.target \ No newline at end of file