summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
-rw-r--r--spotrec2
3 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98233a386e11..3ab4e092aff2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spotrec
pkgdesc = Spotify desktop client recorder for PulseAudio
- pkgver = 0.10.0
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/Bleuzen/SpotRec
arch = any
@@ -13,10 +13,10 @@ pkgbase = spotrec
optdepends = spotify
optdepends = audacity
optdepends = kid3
- source = https://github.com/Bleuzen/SpotRec/releases/download/0.10.0/spotrec.cpython-37.opt-2.pyc
+ source = https://github.com/Bleuzen/SpotRec/releases/download/0.11.0/spotrec.bin
source = spotrec
- sha256sums = a6efb80f7368e36700fc262756fbc2900c0e0c08535fab9a42f5ce98bb6fd7f8
- sha256sums = c16ff3015985fd3877124d4c8b960d8a1b72499d757e72ea37fc4bf38fdca68b
+ sha256sums = 97c4e7fe4086e4a9ee184e2e5ffc477cc1b2e570eb42d84090f7215fb42b2a6a
+ sha256sums = d948a4e77b34eb8bcb8b0f4d3279eaf233cb91082eaf3b389b0a7094fc339b82
pkgname = spotrec
diff --git a/PKGBUILD b/PKGBUILD
index a8c4093d4bd9..73dde3c2fac5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bleuzen <supgesu at gmail dot com>
pkgname=spotrec
-pkgver=0.10.0
+pkgver=0.11.0
pkgrel=1
pkgdesc="Spotify desktop client recorder for PulseAudio"
arch=('any')
@@ -11,15 +11,15 @@ depends=('python' 'python-dbus' 'ffmpeg' 'gawk' 'bash')
optdepends=('spotify'
'audacity'
'kid3')
-source=("${url}/releases/download/${pkgver}/${pkgname}.cpython-37.opt-2.pyc"
+source=("${url}/releases/download/${pkgver}/${pkgname}.bin"
"${pkgname}")
-sha256sums=('a6efb80f7368e36700fc262756fbc2900c0e0c08535fab9a42f5ce98bb6fd7f8'
- 'c16ff3015985fd3877124d4c8b960d8a1b72499d757e72ea37fc4bf38fdca68b')
+sha256sums=('97c4e7fe4086e4a9ee184e2e5ffc477cc1b2e570eb42d84090f7215fb42b2a6a'
+ 'd948a4e77b34eb8bcb8b0f4d3279eaf233cb91082eaf3b389b0a7094fc339b82')
package() {
mkdir -p "$pkgdir"/opt/${pkgname}/
mkdir -p "$pkgdir"/usr/bin/
- install -D ${pkgname}.cpython-37.opt-2.pyc "$pkgdir"/opt/${pkgname}/
+ install -D ${pkgname}.bin "$pkgdir"/opt/${pkgname}/
install -D ${pkgname} "$pkgdir"/usr/bin/
}
diff --git a/spotrec b/spotrec
index 1f1306038b27..93a8d9e2f9e3 100644
--- a/spotrec
+++ b/spotrec
@@ -1,2 +1,2 @@
#!/bin/bash
-python3 /opt/spotrec/spotrec.cpython-37.opt-2.pyc "$@"
+/opt/spotrec/spotrec.bin "$@"