summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD23
2 files changed, 3 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2636eab57949..6bf9ef749a4e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sprofile
pkgdesc = A tool for accessing your spotify statistics without ever leaving the terminal
- pkgver = 0.0.1
+ pkgver = 0.1.0
pkgrel = 1
url = https://github.com/goodboyneon/sprofile
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = sprofile
depends = nodejs>=18
depends = rust
depends = cargo
- source = sprofile-0.0.1.tar.gz::https://github.com/goodboyneon/sprofile/archive/v0.0.1.tar.gz
+ source = sprofile-0.1.0.tar.gz::https://github.com/goodboyneon/sprofile/archive/v0.1.0.tar.gz
sha256sums = d7c51b2d2de5fdb9153467386c55db89b070e2f6d27783805685c3ff796b565d
pkgname = sprofile
diff --git a/PKGBUILD b/PKGBUILD
index a1f095e2106e..a65bc2a3823c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,24 @@
# Maintainer: Sushant Ray <contact@neon.is-a.dev>
pkgname='sprofile'
-pkgver=0.0.1
+pkgver=0.1.0
pkgrel=1
epoch=
pkgdesc="A tool for accessing your spotify statistics without ever leaving the terminal"
arch=('x86_64')
url="https://github.com/goodboyneon/sprofile"
license=('MIT')
-groups=()
depends=('nodejs>=18' 'rust' 'cargo')
makedepends=('git')
-checkdepends=()
-optdepends=()
-provides=()
-conflicts=()
-replaces=()
-backup=()
-options=()
-install=
-changelog=
source=("$pkgname-$pkgver.tar.gz::https://github.com/goodboyneon/$pkgname/archive/v$pkgver.tar.gz")
-noextract=()
sha256sums=("d7c51b2d2de5fdb9153467386c55db89b070e2f6d27783805685c3ff796b565d")
-validpgpkeys=()
-# prepare() {
-# cd "$pkgname-$pkgver"
-# patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
-# }
build() {
cd "$srcdir/$pkgname-$pkgver"
cargo build --release
}
-# check() {
-# cd "$pkgname-$pkgver"
-# make -k check
-# }
-
package() {
cd "$srcdir/$pkgname-$pkgver"
install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"