summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO48
-rw-r--r--PKGBUILD114
2 files changed, 86 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec224ea445e8..c3a23a6b9994 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = spyder-git
pkgdesc = The Scientific Python Development Environment
- pkgver = 5.2.1.r345.gfad14a342
+ pkgver = 6.0.0a1.r358.g2578be8a3
pkgrel = 1
url = https://www.spyder-ide.org/
arch = any
@@ -8,57 +8,61 @@ pkgbase = spyder-git
makedepends = git
makedepends = python-setuptools
makedepends = python-sphinx
- depends = jupyter-nbconvert
depends = python-atomicwrites
depends = python-chardet
depends = python-cloudpickle
+ depends = python-cookiecutter
depends = python-diff-match-patch
depends = python-intervaltree
+ depends = ipython
depends = python-jedi
+ depends = python-jellyfish
+ depends = python-jsonschema
depends = python-keyring
- depends = python-lsp-black
- depends = python-lsp-server
+ depends = jupyter-nbconvert
depends = python-numpydoc
- depends = python-jsonschema
- depends = python-paramiko
depends = python-parso
depends = python-pexpect
depends = python-pickleshare
depends = python-psutil
- depends = python-pycodestyle
- depends = python-pyflakes
depends = python-pygments
depends = python-pylint
- depends = python-pyls-spyder
- depends = python-pympler
+ depends = python-pylint-venv
depends = python-pyqt5
+ depends = python-pyqt5-webengine
+ depends = python-lsp-server
+ depends = python-lsp-black
+ depends = python-pyls-spyder
+ depends = python-pyxdg
depends = python-pyzmq
depends = python-qdarkstyle
depends = python-qstylizer
depends = python-qtawesome
depends = python-qtconsole
- depends = python-rope
+ depends = python-qtpy
depends = python-rtree
+ depends = python-setuptools
depends = python-sphinx
depends = python-spyder-kernels
depends = python-textdistance
depends = python-three-merge
depends = python-watchdog
- depends = python-xdg
depends = autopep8
depends = flake8
- depends = python-cookiecutter
+ depends = python-pycodestyle
depends = python-pydocstyle
- depends = python-pyqtwebengine
- depends = qt5-webkit
+ depends = python-pyflakes
+ depends = python-rope
depends = yapf
- optdepends = cython: run Cython files
- optdepends = python-matplotlib: 2D/3D plotting
- optdepends = python-numpy: N-dimensional arrays
- optdepends = python-pandas: DataFrame and Series support
- optdepends = python-scipy: signal/image processing
- optdepends = python-sympy: symbolic mathematics
- optdepends = python-h5py: HDF5 support
+ depends = python-whatthepatch
+ depends = python-debugpy
+ depends = python-pyuca
+ optdepends = cython: run Cython files in the IPython Console
+ optdepends = python-matplotlib: 2D/3D plotting in the IPython Console
+ optdepends = python-numpy: support for N-dimensional arrays in the Variable Explorer
+ optdepends = python-pandas: support for DataFrames and Series in the Variable Explorer
+ optdepends = python-scipy: support for Matlab workspace in the Variable Explorer
+ optdepends = python-sympy: symbolic mathematics in the IPython Console
provides = spyder
conflicts = spyder
conflicts = spyder3-git
diff --git a/PKGBUILD b/PKGBUILD
index 5761b71c3183..67928ab83da8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: willemw <willemw12@gmail.com>
pkgname=spyder-git
-pkgver=5.2.1.r345.gfad14a342
+pkgver=6.0.0a1.r358.g2578be8a3
pkgrel=1
pkgdesc="The Scientific Python Development Environment"
arch=('any')
@@ -9,60 +9,66 @@ url="https://www.spyder-ide.org/"
license=('MIT')
makedepends=('git' 'python-setuptools' 'python-sphinx')
#'icu'
-depends=('jupyter-nbconvert'
- 'python-atomicwrites'
- 'python-chardet'
- 'python-cloudpickle'
- 'python-diff-match-patch'
- 'python-intervaltree'
- 'python-jedi'
- 'python-keyring'
- 'python-lsp-black'
- 'python-lsp-server'
- 'python-numpydoc'
- 'python-jsonschema'
- 'python-paramiko'
- 'python-parso'
- 'python-pexpect'
- 'python-pickleshare'
- 'python-psutil'
- 'python-pycodestyle'
- 'python-pyflakes'
- 'python-pygments'
- 'python-pylint'
- 'python-pyls-spyder'
- 'python-pympler'
- 'python-pyqt5'
- 'python-pyzmq'
- 'python-qdarkstyle'
- 'python-qstylizer'
- 'python-qtawesome'
- 'python-qtconsole'
- 'python-rope'
- 'python-rtree'
- 'python-sphinx'
- 'python-spyder-kernels'
- 'python-textdistance'
- 'python-three-merge'
- 'python-watchdog'
- 'python-xdg'
+depends=(
+ python-atomicwrites
+ python-chardet
+ python-cloudpickle
+ python-cookiecutter
+ python-diff-match-patch
+ python-intervaltree
+ ipython
+ python-jedi
+ python-jellyfish
+ python-jsonschema
+ python-keyring
+ jupyter-nbconvert
+ python-numpydoc
+ python-parso
+ python-pexpect
+ python-pickleshare
+ python-psutil
+ python-pygments
+ python-pylint
+ python-pylint-venv
+ python-pyqt5
+ python-pyqt5-webengine
+ python-lsp-server
+ python-lsp-black
+ python-pyls-spyder
+ python-pyxdg
+ python-pyzmq
+ python-qdarkstyle
+ python-qstylizer
+ python-qtawesome
+ python-qtconsole
+ python-qtpy
+ python-rtree
+ python-setuptools
+ python-sphinx
+ python-spyder-kernels
+ python-textdistance
+ python-three-merge
+ python-watchdog
+ autopep8
+ flake8
+ python-pycodestyle
+ python-pydocstyle
+ python-pyflakes
+ python-rope
+ yapf
+ python-whatthepatch
- 'autopep8'
- 'flake8'
- 'python-cookiecutter'
- 'python-pydocstyle'
- 'python-pyqtwebengine'
- 'qt5-webkit'
- 'yapf')
-#'pyside2: Qt-Python bindings'
-optdepends=('cython: run Cython files'
- 'python-matplotlib: 2D/3D plotting'
- 'python-numpy: N-dimensional arrays'
- 'python-pandas: DataFrame and Series support'
- 'python-scipy: signal/image processing'
- 'python-sympy: symbolic mathematics'
-
- 'python-h5py: HDF5 support')
+ python-debugpy
+ python-pyuca
+)
+optdepends=(
+ 'cython: run Cython files in the IPython Console'
+ 'python-matplotlib: 2D/3D plotting in the IPython Console'
+ 'python-numpy: support for N-dimensional arrays in the Variable Explorer'
+ 'python-pandas: support for DataFrames and Series in the Variable Explorer'
+ 'python-scipy: support for Matlab workspace in the Variable Explorer'
+ 'python-sympy: symbolic mathematics in the IPython Console'
+)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}" 'spyder3-git')
replaces=('spyder3-git')