summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md92
-rw-r--r--PKGBUILD4
3 files changed, 91 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 515f245e9105..7f8b6bdb308c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sqlcl
pkgdesc = SQL Developer command line interface for Oracle
- pkgver = 23.4.0.023.2321
+ pkgver = 24.1.0.087.0929
pkgrel = 1
url = https://www.oracle.com/database/sqldeveloper/technologies/sqlcl
changelog = CHANGELOG.md
@@ -8,9 +8,9 @@ pkgbase = sqlcl
license = custom
depends = bash
depends = java-runtime>=8
- source = sqlcl-23.4.0.023.2321.zip::https://download.oracle.com/otn_software/java/sqldeveloper/sqlcl-23.4.0.023.2321.zip
+ source = sqlcl-24.1.0.087.0929.zip::https://download.oracle.com/otn_software/java/sqldeveloper/sqlcl-24.1.0.087.0929.zip
source = sqlcl.sh
- sha256sums = f0adb2b8b60c248f5f15e0dc1e95876262316460b4ebf85e601116d73dad19ce
+ sha256sums = 0c7a775abc2ba35a1a044c353bb73244624a6e10f6cfce8c798d97ab6bf3a354
sha256sums = 34c5f2be48639dcd8ec9f38f950916a394ae399a0e583fbde4020acdccf951e0
pkgname = sqlcl
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 026f452eda95..df4cba0199f0 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,14 +1,94 @@
+# New Features in 24.1.0
+
+* SQLcl users now have the ability to run tasks in the background.
+ * There are three new commands related to this:
+ * _background | bg {OPTIONS} \<commandspec\>_
+ * Run a SQLcl command in the background as a task.
+ * Ex. _background -taskname generate-emps ddl employees_
+ * Started task with id: 0
+ * _jobs | jb {SUBCOMMAND} {OPTIONS}_
+ * List and manage the background tasks running.
+ * Ex. _jobs_
+ * 0: \[ Running \] generate-em (C:\\Users\\ztalke\\.sqlcl\\jobslogs\\generateemps.log)
+ * Ex. _jobs logs -id 0_
+ * CREATE TABLE "HR"."EMPLOYEES"
+ * ( "EMPLOYEE\_ID" NUMBER(6,0),
+ * **…**
+ * _wait4 | w4 {OPTIONS} {PARAMETERS}_
+ * Wait for one or more background tasks to finish before continuing with processing.
+ * Ex. _wait4 generate-emps -delay 5000_
+* Color highlighting for keywords and errors in SQLcl are now enabled by default (controlled by _set highlighting_ command).
+* Liquibase Functionality in SQLcl
+ * _\-overwrite-files_ parameter added to the Liquibase _generate_ commands. This allows existing files with the same name to be replaced when generating changelogs. Beneficial for automation pipelines.
+ * _\-show-summary_ parameter added to the Liquibase _update_ commands. This produces a list of any changes not applied during an update and why they were skipped.
+ * There are three levels of detail with this parameter: OFF -> SUMMARY -> VERBOSE
+ * For Liquibase commands, all parameters that take Boolean values must now be explicitly stated as either true or false if they are referenced in a command. Under the hood, this allows us to better stay in sync with open-source Liquibase parameter changes moving forward.
+ * Ex. 23.4 Command: _liquibase update -output-default-schema_
+ * Ex. 24.1 Command: _liquibase update -output-default-schema true_
+ * Listed parameters have been adjusted back to 23.3 definitions to better suit long term consistency (23.3 -> 23.4 -> 24.1).
+ * _\-secure-parsing -> -no-secure-parsing_ -> _\-secure-parsing_
+ * _\-runonchange -> -dontrunonchange_ -> _\-runonchange_
+ * _\-runalways -> -dontrunalways_ -> _\-runalways_
+ * _\-skipexportdate -> -keepexportdate_ -> _\-skipexportdate_
+ * _\-exporiginalids -> -dontexporiginalids_ -> _\-exporiginalids_
+ * The parameter _\-fail-on-error_ now defaults as false.
+ * The parameter _\-verbose_ now defaults as true.
+
+# Important Update With Liquibase Files
+
+* For cross-schema use, changelog files generated before SQLcl 23.4 may require regeneration or manual updates. The need for these alterations are only necessary if you are changing schema names between your export and import with these pre 23.4 changelogs.
+ * If you don’t regenerate your changelogs or make the manual adjustments described below:
+ * Changelogs containing schema names will only be able to be applied to the schema named in them regardless of provided parameters.
+ * Changelogs not containing schema names will only be able to be applied to the schema you are currently connected to with SQLcl regardless of provided parameters.
+ * 23.4 introduced a %USER\_NAME% replacement for schema name stored in changesets.
+ * To manually update your changelogs with the proper %USER\_NAME% substitution, there are two types of changes:
+ * For changelogs with the \<SCHEMA\>\</SCHEMA\> XML element, replace the content inside with %USER\_NAME%
+ * Example: \<SCHEMA\>%USER\_NAME%\</SCHEMA\>
+ * For changelogs that utilize SQL within the CDATA field, attach "%USER\_NAME%". to the front of all database object references. If a schema name is in these locations, replace it with "%USER\_NAME%".
+ * Example:  \<n0:source\>\<!\[CDATA\[CREATE OR REPLACE EDITIONABLE PROCEDURE "%USER\_NAME%"."P\_SQLCLERROR\_PROCEDURE" ...
+ * Example:  \<n0:source\>\<!\[CDATA\[ALTER TABLE "%USER\_NAME%"."EMPLOYEES" ADD CONSTRAINT "EMP\_JOB\_FK" FOREIGN KEY ("JOB\_ID") REFERENCES "%USER\_NAME%"."JOBS" ("JOB\_ID") ENABLE;\]\]\>\</n0:source\>
+
+# Issues Fixed in 24.1.0
+
+The main bugs of note this release are:
+
+* Can’t connect to database with SQLcl using both _\-name_ and _@\[script\]_ parameters.
+* _DESCRIBE packages_ command running slow on larger packages.
+* SQLcl ignores JAVA\_HOME if JAVA is found in path.
+* Liquibase Functionality in SQLcl
+ * Global parameters not being properly applied to all Liquibase commands.
+ * Examples: _\-log_, _\-debug_
+ * Liquibase changelogs cancelled with a substitution error still result with changelog marked as ran in databasechangelog table.
+ * Liquibase unable to generate tables with foreign key constraints.
+ * _liquibase data_ command giving data definition language (DDL) XML content instead of data XML.
+ * Specific supporting objects for Liquibase are not being generated when _liquibase update_ command is ran for the first time in a schema under certain circumstances.
+ * DATABASECHANGELOG\_ACTIONS\_PK INDEX
+ * DATABASECHANGELOG\_ACTIONS TABLE
+ * DATABASECHANGELOG\_ACTIONS\_TRG TRIGGER
+ * DATABASECHANGELOG\_DETAILS VIEW
+ * Liquibase error messaging and the output for _\-debug_ and _\-log_ parameters lacking enough detail in certain circumstances.
+ * Only one _\-search-path_ parameter can be used at a time with Liquibase.
+ * Index changes not being deployed to target with Liquibase.
+ * Folders names created with the _\-split_ parameter using _liquibase generate-schema_ generated as uppercase instead of lowercase.
+ * _liquibase generate-schema_ failing at times with error JAVA.SQL.SQL.EXPECTION: ORA-12899: VALUE TOO LARGE FOR COLUMN.
+ * Liquibase failing with JAVA.SQL.SQLEXCEPTION: ORA-31604: INVALID NAME PARAMETER when using _\-grants_ parameter with _liquibase generate-schema._
+ * Liquibase consistency issues with runOracleScript/runApexScript changes of sourceType=File and realtiveToChangelogFile=true.
+ * Liquibase issue where SQL errors in runoraclescript changesets do not stop _liquibase update_ execution.
+ * SQLcl Liquibase not outputting open-source Liquibase version info when running.
+
+If your bug fix isn’t listed above, please refer to [My Oracle Support](https://support.oracle.com/portal/) to check its status.
+
# New Features in 23.4.0
- Updated the underlying open-source Liquibase version from 4.18 to 4.24 for SQLcl's Oracle enhanced Liquibase commands
- Schema Names in Liquibase Changelogs Tokenized In 23.4 and Moving Forward:
- In order to properly support the schema possibilities that can be used by the changeset section of a changelog, it became necessary to tokenize the schema name stored in changesets through the format %USER_NAME% in SQLcl 23.4 and moving forward. This tokenization allows for the proper setting of the schema name when generating the database object data definition language (DDL) and avoids edge case complications.
- For changelogs you have generated prior to 23.4, in order for them to be fully supported in 23.4 and beyond, you will either need to regenerate these changelogs in SQLcl 23.4 or a future version or manually alter your changelogs with %USER_NAME% as so:
- - For changelogs with the <SCHEMA></SCHEMA> XML element, replace the content inside with %USER_NAME%
- - Example: <SCHEMA>%USER_NAME%</SCHEMA>
+ - For changelogs with the \<SCHEMA\>\</SCHEMA\> XML element, replace the content inside with %USER_NAME%
+ - Example: \<SCHEMA\>%USER_NAME%\</SCHEMA\>
- For changelogs that utilize SQL within the CDATA field, attach "%USER_NAME%". to the front of all database object references. If a schema name is in these locations, replace it with "%USER_NAME%".
- - Example: <n0:source><![CDATA[CREATE OR REPLACE EDITIONABLE PROCEDURE "%USER_NAME%"."P_SQLCLERROR_PROCEDURE" ...
- - Example: <n0:source><![CDATA[ALTER TABLE "%USER_NAME%"."EMPLOYEES" ADD CONSTRAINT "EMP_JOB_FK" FOREIGN KEY ("JOB_ID") REFERENCES "%USER_NAME%"."JOBS" ("JOB_ID") ENABLE;]]></n0:source>
+ - Example: \<n0:source\>\<![CDATA[CREATE OR REPLACE EDITIONABLE PROCEDURE "%USER_NAME%"."P_SQLCLERROR_PROCEDURE" ...
+ - Example: \<n0:source\>\<![CDATA[ALTER TABLE "%USER_NAME%"."EMPLOYEES" ADD CONSTRAINT "EMP_JOB_FK" FOREIGN KEY ("JOB_ID") REFERENCES "%USER_NAME%"."JOBS" ("JOB_ID") ENABLE;]]\>\</n0:source\>
- The need for these alterations are only necessary if you are changing schema names between your export and import.
- The new alias search command allows you to search for aliases and return a resulting list in the syntax of alias search [search string]. The search string will check the contents of your aliases’ name, description, and query.
- To learn more use the help alias search command in SQLcl
@@ -29,7 +109,7 @@
# Issues Fixed in 23.4.0
There have been many issues fixed in this quarterly release. The main ones of note are:
-- Thick Driver Support - Changed -oci to -thick on commandline. sql -thick <url>
+- Thick Driver Support - Changed -oci to -thick on commandline. sql -thick \<url\>
- MKStore command upgraded to removed Java SecurityManager restriction
- JDBC upgraded to 21.12.0.0.230906
- SQLCL now checks for java in this order: Embedded JRE > JAVAHOME > $ORACLEHOME > PATH
@@ -37,7 +117,7 @@ There have been many issues fixed in this quarterly release. The main ones of no
- TNSAdmin search order fixed to: $HOME > $CWD > (windows registry) > $ORACLE_HOME
- SQL Parser fully supports Database 23c updated syntax
- SQL Error positions now correctly reported
-- Help for commands now standardized to help <command>
+- Help for commands now standardized to help \<command\>
- liquibase update -changelog-file controller.xml fails to update table object at target if constraints are deleted at source
- SQLcl liquibase changelog tables showing in the controller if they are renamed
- SQLcl liquibase removing schema name from strings inside pl/sql objects
diff --git a/PKGBUILD b/PKGBUILD
index 25eb2e27d8bb..5bfe492ecdd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Arne Hoch <arne@derhoch.de>
pkgname=sqlcl
-pkgver='23.4.0.023.2321'
+pkgver='24.1.0.087.0929'
pkgrel=1
pkgdesc='SQL Developer command line interface for Oracle'
arch=('any')
@@ -14,7 +14,7 @@ changelog=CHANGELOG.md
depends=('bash' 'java-runtime>=8')
source=("$pkgname-$pkgver.zip::https://download.oracle.com/otn_software/java/sqldeveloper/$pkgname-$pkgver.zip"
"$pkgname.sh")
-sha256sums=('f0adb2b8b60c248f5f15e0dc1e95876262316460b4ebf85e601116d73dad19ce'
+sha256sums=('0c7a775abc2ba35a1a044c353bb73244624a6e10f6cfce8c798d97ab6bf3a354'
'34c5f2be48639dcd8ec9f38f950916a394ae399a0e583fbde4020acdccf951e0')
package() {