summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD48
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..179358bda1b1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+# Generated by mksrcinfo v8
+# Thu Feb 25 21:24:47 UTC 2016
+pkgbase = squeezelite-r2-git
+ pkgdesc = Lightweight headless squeezebox emulator - version r2
+ pkgver = v1.8.2.R2.r1.g681fc3d
+ pkgrel = 1
+ url = http://www.marcoc1712.it/
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = GPL3
+ makedepends = git
+ makedepends = alsa-lib
+ makedepends = faad2
+ makedepends = flac
+ makedepends = libmad
+ makedepends = libvorbis
+ makedepends = mpg123
+ makedepends = portaudio
+ depends = alsa-lib
+ optdepends = faad2: Support for decoding AAC
+ optdepends = flac: Support for decoding FLAC
+ optdepends = libmad: Support for decoding MP3
+ optdepends = libvorbis: Support for decoding Ogg Vorbis
+ optdepends = mpg123: Support for decoding MP3
+ optdepends = portaudio: Use of binary using portaudio for output
+ provides = squeezelite
+ conflicts = squeezelite
+ source = git+https://github.com/marcoc1712/squeezelite-R2
+ sha256sums = SKIP
+
+pkgname = squeezelite-r2-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de91ff4266d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: AudioLinux <audiolinux AT fastmail DOT fm>
+
+# Contributor: Christian Hesse <mail@eworm.de
+# Contributor: Mika Fischer <mika.fischer@zoopnet.de>
+
+pkgname=squeezelite-r2-git
+pkgver=v1.8.2.R2.r1.g681fc3d
+pkgrel=1
+pkgdesc='Lightweight headless squeezebox emulator - version r2'
+arch=('i686' 'x86_64' 'armv6h')
+url='http://www.marcoc1712.it/'
+license=(GPL3)
+depends=('alsa-lib')
+makedepends=('git' 'alsa-lib' 'faad2' 'flac' 'libmad' 'libvorbis' 'mpg123'
+ 'portaudio')
+optdepends=('faad2: Support for decoding AAC'
+ 'flac: Support for decoding FLAC'
+ 'libmad: Support for decoding MP3'
+ 'libvorbis: Support for decoding Ogg Vorbis'
+ 'mpg123: Support for decoding MP3'
+ 'portaudio: Use of binary using portaudio for output')
+provides=('squeezelite')
+conflicts=('squeezelite')
+source=('git+https://github.com/marcoc1712/squeezelite-R2')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd squeezelite-R2/
+ git describe --long --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/\(//g;s/\)//g'
+}
+
+build() {
+ cd squeezelite-R2/
+
+ # build squeezelite
+ make
+
+}
+
+package() {
+ cd squeezelite-R2/
+
+ # Install binaries
+ install -Dm755 squeezelite-R2 "${pkgdir}/usr/bin/squeezelite-r2"
+ install -Dm644 "LICENSE.txt" "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+
+}
+