summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD23
2 files changed, 26 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c57f3c1f27f..636428cd5004 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Tue May 16 00:46:08 UTC 2017
+# Sat Jul 29 10:38:17 UTC 2017
pkgbase = srain
- pkgdesc = It does not look like a irc client
- pkgver = 0.05.1
- pkgrel = 4
+ pkgdesc = Modern, beautiful IRC client written in GTK+ 3
+ pkgver = 0.06
+ pkgrel = 1
url = https://github.com/SilverRainZ/srain
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
makedepends = make
makedepends = gcc
makedepends = pkg-config
@@ -15,15 +16,17 @@ pkgbase = srain
makedepends = imagemagick
depends = gtk3
depends = python
- depends = libircclient
depends = curl
depends = libnotify
- optdepends = python-urllib3
- optdepends = python-requests
+ depends = libconfig
+ optdepends = glib-networking: TLS connection support
+ optdepends = python-sphinx: for generating documentation
+ optdepends = python-urllib3: avatar and pastebin support
+ optdepends = python-requests: avatar and pastebin support
provides = srain
conflicts = srain-git
- source = https://github.com/SilverRainZ/srain/archive/0.05.1.tar.gz
- sha256sums = 2c68b500f94b804b44e15588194e03d07e340a95455cac8ad50524a1c21ba2e3
+ source = https://github.com/SilverRainZ/srain/archive/0.06.tar.gz
+ sha256sums = 2bbe3b9e76965ca3d7b9742c823be2468b611383404ada52cf3962c462e49057
pkgname = srain
diff --git a/PKGBUILD b/PKGBUILD
index 70f8c5c28efb..6a381ee74ac6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
-# Maintainer: SY Zhang <lastavengers@outlook.com>
+# Maintainer: Shengyu Zhang <arch at srain.im>
pkgname=srain
-pkgver=0.05.1
-pkgrel=4
-pkgdesc="It does not look like a irc client"
+pkgver=0.06
+pkgrel=1
+pkgdesc="Modern, beautiful IRC client written in GTK+ 3"
arch=('i686' 'x86_64')
license=('GPL')
url="https://github.com/SilverRainZ/srain"
-depends=('gtk3' 'python' 'libircclient' 'curl' 'libnotify')
-optdepends=('python-urllib3' 'python-requests')
-makedepends=('make' 'gcc' 'pkg-config' 'gettext' 'imagemagick')
+depends=('gtk3' 'python' 'curl' 'libnotify' 'libconfig')
+makedepends=('git' 'make' 'gcc' 'pkg-config' 'gettext' 'imagemagick')
+optdepends=(
+ 'glib-networking: TLS connection support'
+ 'python-sphinx: for generating documentation'
+ 'python-urllib3: avatar and pastebin support'
+ 'python-requests: avatar and pastebin support'
+ )
conflicts=('srain-git')
provides=('srain')
source=("https://github.com/SilverRainZ/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('2c68b500f94b804b44e15588194e03d07e340a95455cac8ad50524a1c21ba2e3')
+sha256sums=('2bbe3b9e76965ca3d7b9742c823be2468b611383404ada52cf3962c462e49057')
build() {
cd ${pkgname}-${pkgver}
mkdir build || true
- ./configure --prefix=/usr --disable-debug
+ ./configure --prefix=/usr --config-dir=/etc --disable-debug
make
}