summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--0001-cmake-fix-build-for-cmake-option-BUILD_SHARED_LIBS-O.patch66
-rw-r--r--0002-add-missing-include-for-build-with-GCC-12.patch27
-rw-r--r--0003-adt-fsm-ignore-GCC-warning-for-template-specializati.patch53
-rw-r--r--0004-lib-asn1_utils-fix-out-of-bounds-access-on-zero-size.patch37
-rw-r--r--0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch32
-rw-r--r--PKGBUILD2
7 files changed, 2 insertions, 217 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 958d50daa144..5bf61f8a27e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = srsran-git
pkgdesc = Open source SDR LTE software suite from Software Radio Systems (SRS)
- pkgver = 22.4.1.r0.gce8a3cae1
+ pkgver = 22.10.0.r0.g254cc719a
pkgrel = 1
url = https://www.srsran.com
arch = x86_64
diff --git a/0001-cmake-fix-build-for-cmake-option-BUILD_SHARED_LIBS-O.patch b/0001-cmake-fix-build-for-cmake-option-BUILD_SHARED_LIBS-O.patch
deleted file mode 100644
index 25b73564ba85..000000000000
--- a/0001-cmake-fix-build-for-cmake-option-BUILD_SHARED_LIBS-O.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-From c5d5d45574ecc3ab86347dbab8fc9d27d1815248 Mon Sep 17 00:00:00 2001
-From: Robert Falkenberg <robert.falkenberg@srs.io>
-Date: Tue, 10 May 2022 09:14:25 +0200
-Subject: [PATCH] cmake: fix build for cmake option BUILD_SHARED_LIBS=ON
-
-The cmake option BUILD_SHARED_LIBS (off by default) causes all
-libraries to be built as shared libraries if not unless explicitly
-stated otherwise.
-Since test-helper libraries do not export their symbols, linking
-fails if built as shared library.
-Therefore, this change explicitly configures these helpers as STATIC.
----
- srsenb/test/rrc/CMakeLists.txt | 2 +-
- srsgnb/src/stack/mac/test/CMakeLists.txt | 4 ++--
- srsgnb/src/stack/rrc/test/CMakeLists.txt | 2 +-
- 3 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/srsenb/test/rrc/CMakeLists.txt b/srsenb/test/rrc/CMakeLists.txt
-index 06ecb4221..fb6694fd4 100644
---- a/srsenb/test/rrc/CMakeLists.txt
-+++ b/srsenb/test/rrc/CMakeLists.txt
-@@ -6,7 +6,7 @@
- # the distribution.
- #
-
--add_library(test_helpers test_helpers.cc)
-+add_library(test_helpers STATIC test_helpers.cc)
- target_link_libraries(test_helpers srsenb_rrc srsenb_common rrc_asn1 rrc_nr_asn1 s1ap_asn1 srsran_common enb_cfg_parser ${LIBCONFIGPP_LIBRARIES})
-
- add_executable(rrc_meascfg_test rrc_meascfg_test.cc)
-diff --git a/srsgnb/src/stack/mac/test/CMakeLists.txt b/srsgnb/src/stack/mac/test/CMakeLists.txt
-index 6afaccc59..2441f5f8a 100644
---- a/srsgnb/src/stack/mac/test/CMakeLists.txt
-+++ b/srsgnb/src/stack/mac/test/CMakeLists.txt
-@@ -8,7 +8,7 @@
-
- set_directory_properties(PROPERTIES LABELS "sched;nr")
-
--add_library(sched_nr_test_suite sched_nr_common_test.cc sched_nr_ue_ded_test_suite.cc sched_nr_sim_ue.cc)
-+add_library(sched_nr_test_suite STATIC sched_nr_common_test.cc sched_nr_ue_ded_test_suite.cc sched_nr_sim_ue.cc)
- target_link_libraries(sched_nr_test_suite srsgnb_mac srsran_common rrc_nr_asn1)
-
- add_executable(sched_nr_parallel_test sched_nr_parallel_test.cc)
-@@ -53,4 +53,4 @@ target_link_libraries(sched_nr_test
- rrc_nr_asn1
- srsran_common ${CMAKE_THREAD_LIBS_INIT}
- ${Boost_LIBRARIES})
--add_nr_test(sched_nr_test sched_nr_test)
-\ No newline at end of file
-+add_nr_test(sched_nr_test sched_nr_test)
-diff --git a/srsgnb/src/stack/rrc/test/CMakeLists.txt b/srsgnb/src/stack/rrc/test/CMakeLists.txt
-index 103b1bb38..efca40807 100644
---- a/srsgnb/src/stack/rrc/test/CMakeLists.txt
-+++ b/srsgnb/src/stack/rrc/test/CMakeLists.txt
-@@ -6,7 +6,7 @@
- # the distribution.
- #
-
--add_library(rrc_nr_test_helpers rrc_nr_test_helpers.cc)
-+add_library(rrc_nr_test_helpers STATIC rrc_nr_test_helpers.cc)
-
- add_executable(rrc_nr_test rrc_nr_test.cc)
- target_link_libraries(rrc_nr_test srsgnb_rrc srsgnb_rrc_config_utils srsran_common rrc_nr_asn1 rrc_nr_test_helpers srsgnb_mac ${ATOMIC_LIBS})
---
-2.36.1
-
diff --git a/0002-add-missing-include-for-build-with-GCC-12.patch b/0002-add-missing-include-for-build-with-GCC-12.patch
deleted file mode 100644
index 4de48093e32a..000000000000
--- a/0002-add-missing-include-for-build-with-GCC-12.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 9687af766089e11005bdb50c53d37f6809409b2b Mon Sep 17 00:00:00 2001
-From: Robert Falkenberg <robert.falkenberg@srs.io>
-Date: Thu, 12 May 2022 06:42:15 +0200
-Subject: [PATCH] add missing include for build with GCC 12
-
-Related info: https://gcc.gnu.org/gcc-12/porting_to.html
----
- lib/include/srsran/srslog/bundled/fmt/core.h | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/lib/include/srsran/srslog/bundled/fmt/core.h b/lib/include/srsran/srslog/bundled/fmt/core.h
-index d676f27e5..04a85f295 100644
---- a/lib/include/srsran/srslog/bundled/fmt/core.h
-+++ b/lib/include/srsran/srslog/bundled/fmt/core.h
-@@ -8,7 +8,8 @@
- #ifndef FMT_CORE_H_
- #define FMT_CORE_H_
-
--#include <cstdio> // std::FILE
-+#include <array>
-+#include <cstdio> // std::FILE
- #include <cstring>
- #include <functional>
- #include <iterator>
---
-2.36.1
-
diff --git a/0003-adt-fsm-ignore-GCC-warning-for-template-specializati.patch b/0003-adt-fsm-ignore-GCC-warning-for-template-specializati.patch
deleted file mode 100644
index b09a59833ad7..000000000000
--- a/0003-adt-fsm-ignore-GCC-warning-for-template-specializati.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From aa9f844630d0627018c7ecb7008e309e1d04905e Mon Sep 17 00:00:00 2001
-From: Robert Falkenberg <robert.falkenberg@srs.io>
-Date: Fri, 13 May 2022 12:36:20 +0200
-Subject: [PATCH] adt,fsm: ignore GCC warning for template specialization w/wo
- defaults for ReactFn or GuardFn
-
----
- lib/include/srsran/adt/fsm.h | 8 ++++++++
- 1 file changed, 8 insertions(+)
-
-diff --git a/lib/include/srsran/adt/fsm.h b/lib/include/srsran/adt/fsm.h
-index 1e00946d7..4583b1f19 100644
---- a/lib/include/srsran/adt/fsm.h
-+++ b/lib/include/srsran/adt/fsm.h
-@@ -332,6 +332,9 @@ public:
- constexpr static void (Derived::*react_fn)(SrcState&, const Event&) = ReactFn;
- constexpr static bool (Derived::*guard_fn)(SrcState&, const Event&) = GuardFn;
-
-+ // ignore warning "never nullptr" for template specialization w/wo defaults for ReactFn or GuardFn
-+ _Pragma("GCC diagnostic push"); // save current diagnostic config
-+ _Pragma("GCC diagnostic ignored \"-Waddress\""); // ignore -Waddress
- static bool react(derived_view* f, src_state_t& s, const event_t& ev)
- {
- if (guard_fn == nullptr or (f->*guard_fn)(s, ev)) {
-@@ -342,6 +345,7 @@ public:
- }
- return false;
- }
-+ _Pragma("GCC diagnostic pop"); // restore diagnostic config
-
- template <typename SrcState2, typename Event2>
- using is_match = std::is_same<type_list<SrcState2, Event2>, type_list<src_state_t, event_t> >;
-@@ -363,6 +367,9 @@ public:
- constexpr static void (Derived::*react_fn)(const Event&) = ReactFn;
- constexpr static bool (Derived::*guard_fn)(const Event&) = GuardFn;
-
-+ // ignore warning "never nullptr" for template specialization w/wo defaults for ReactFn or GuardFn
-+ _Pragma("GCC diagnostic push"); // save current diagnostic config
-+ _Pragma("GCC diagnostic ignored \"-Waddress\""); // ignore -Waddress
- template <typename SrcState>
- static bool react(derived_view* f, SrcState& s, const event_t& ev)
- {
-@@ -374,6 +381,7 @@ public:
- }
- return false;
- }
-+ _Pragma("GCC diagnostic pop"); // restore diagnostic config
-
- template <typename SrcState2, typename Event2>
- using is_match = std::is_same<Event2, event_t>;
---
-2.36.1
-
diff --git a/0004-lib-asn1_utils-fix-out-of-bounds-access-on-zero-size.patch b/0004-lib-asn1_utils-fix-out-of-bounds-access-on-zero-size.patch
deleted file mode 100644
index 7de6fdf0625b..000000000000
--- a/0004-lib-asn1_utils-fix-out-of-bounds-access-on-zero-size.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From 0c9ba5b87ee246b772c9deb2993834f0b7fc088b Mon Sep 17 00:00:00 2001
-From: Robert Falkenberg <robert.falkenberg@srs.io>
-Date: Fri, 13 May 2022 16:47:52 +0200
-Subject: [PATCH] lib,asn1_utils: fix out of bounds access on zero-sized array
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-* fix error: ... offset 0 is out of the bounds [0, 0] [-Werror=array-bounds]
-* fix note: destination object of size 0 allocated by ‘operator new []’
---> data_ = new T[cap_];
----
- lib/include/srsran/asn1/asn1_utils.h | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/lib/include/srsran/asn1/asn1_utils.h b/lib/include/srsran/asn1/asn1_utils.h
-index 87696d7b6..f1dcfcd74 100644
---- a/lib/include/srsran/asn1/asn1_utils.h
-+++ b/lib/include/srsran/asn1/asn1_utils.h
-@@ -193,8 +193,12 @@ public:
- {
- size_ = nof_items;
- cap_ = nof_items;
-- data_ = new T[cap_];
-- std::copy(ptr, ptr + size_, data_);
-+ if (ptr != NULL) {
-+ data_ = new T[cap_];
-+ std::copy(ptr, ptr + size_, data_);
-+ } else {
-+ data_ = NULL;
-+ }
- }
- ~dyn_array()
- {
---
-2.36.1
-
diff --git a/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch b/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch
deleted file mode 100644
index e48bb01480bf..000000000000
--- a/0005-cmake-gcc-disable-Werror-maybe-uninitialized-for-GCC.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-From 21a4a675dd74167552e6c78de432cd627e395481 Mon Sep 17 00:00:00 2001
-From: Robert Falkenberg <robert.falkenberg@srs.io>
-Date: Tue, 17 May 2022 15:10:41 +0200
-Subject: [PATCH] cmake/gcc: disable [-Werror=maybe-uninitialized] for GCC >=
- 12.1.0
-
-With GCC 12.1.0 there are numerous false-positive warnings on
-"maybe uninitialized" variables.
----
- CMakeLists.txt | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 664cadb94..694b6373a 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -540,6 +540,12 @@ if(NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 5.0)
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Werror")
- endif()
-
-+# GCC >= 12.1.0: Disable analysis on "maybe-uninitialized" variables because of the high false-positive rate
-+if(CMAKE_COMPILER_IS_GNUCXX AND NOT CMAKE_CXX_COMPILER_VERSION VERSION_LESS 12.1)
-+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wno-maybe-uninitialized")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-maybe-uninitialized")
-+endif()
-+
- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
- # Increase inlining limit to allow gcc compilation on e.g. RPi2
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --param large-function-growth=1600")
---
-2.36.1
-
diff --git a/PKGBUILD b/PKGBUILD
index 69c525702d85..4ff39e97d025 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgbase=srsran-git
pkgname=$pkgbase
_pkgname=srsRAN
-pkgver=22.4.1.r0.gce8a3cae1
+pkgver=22.10.0.r0.g254cc719a
pkgrel=1
pkgdesc='Open source SDR LTE software suite from Software Radio Systems (SRS)'
arch=('x86_64')