summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD21
3 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c53bd33d071b..8d108f004346 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ssb-patchwork-git
pkgdesc = A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
- pkgver = 3.10.1.r13.g72852e6b
- pkgrel = 3
+ pkgver = 3.10.1.r301.g9750bc4d
+ pkgrel = 1
url = https://github.com/ssbc/patchwork
arch = i686
arch = x86_64
@@ -17,8 +17,8 @@ pkgbase = ssb-patchwork-git
depends = gtk2
depends = alsa-lib
depends = nss
- depends = electron
- provides = ssb-patchwork=3.10.1.r13.g72852e6b
+ depends = electron2
+ provides = ssb-patchwork=3.10.1.r301.g9750bc4d
conflicts = ssb-patchwork
options = !strip
source = git+https://github.com/ssbc/patchwork.git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..85de9cf93344
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+src
diff --git a/PKGBUILD b/PKGBUILD
index 80a25231a26e..095b150be416 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname=ssb-patchwork-git
_srcname=patchwork
_aurname=ssb-patchwork
-pkgver=3.10.1.r13.g72852e6b
-pkgrel=3
+pkgver=3.10.1.r301.g9750bc4d
+pkgrel=1
pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
arch=('i686' 'x86_64')
url="https://github.com/ssbc/patchwork"
license=('AGPL3')
-depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron')
+depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'alsa-lib' 'nss' 'electron2')
makedepends=('nodejs' 'npm')
provides=("ssb-patchwork=${pkgver}")
conflicts=('ssb-patchwork')
@@ -36,8 +36,19 @@ pkgver() {
build() {
cd "${srcdir}/${_srcname}"
- npm ci --only=production
- npm run rebuild
+ # Electron's version.
+ export npm_config_target=$(electron2 -v)
+ # The architecture of Electron, can be ia32 or x64.
+ export npm_config_arch=x64
+ export npm_config_target_arch=x64
+ # Download headers for Electron.
+ export npm_config_disturl=https://atom.io/download/electron
+ # Tell node-pre-gyp that we are building for Electron.
+ export npm_config_runtime=electron
+ # Tell node-pre-gyp to build module from source code.
+ export npm_config_build_from_source=true
+
+ npm install --only=production
}
package() {