summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD36
-rwxr-xr-xrun.sh4
-rw-r--r--ssb-patchwork.desktop10
4 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9b5ccbc35089
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+# Generated by mksrcinfo v8
+# Sat Sep 9 19:25:26 UTC 2017
+pkgbase = ssb-patchwork
+ pkgdesc = A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
+ pkgver = 3.6.4
+ pkgrel = 1
+ url = https://github.com/ssbc/patchwork
+ arch = i686
+ arch = x86_64
+ license = AGPL3
+ depends = libxtst
+ depends = libxext
+ depends = libxkbfile
+ depends = gconf
+ depends = libsodium
+ depends = libxss
+ depends = gtk2
+ depends = nodejs
+ depends = npm
+ depends = alsa-lib
+ depends = nss
+ options = !strip
+ source = https://github.com/ssbc/patchwork/archive/v3.6.4.tar.gz
+ source = run.sh
+ source = ssb-patchwork.desktop
+ md5sums = 2d2b63a975486947d147e681429db749
+ md5sums = 26bbb4043ff690355e9d83f539484644
+ md5sums = 2b507044b1ae8f5d00aea5b148ec65f0
+
+pkgname = ssb-patchwork
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..71aa2321e060
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Daniel Landau <daniel@landau.fi>
+
+pkgname=ssb-patchwork
+_upstream=patchwork
+pkgver=3.6.4
+pkgrel=1
+pkgdesc="A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)"
+arch=('i686' 'x86_64')
+url="https://github.com/ssbc/patchwork"
+license=('AGPL3')
+depends=('libxtst' 'libxext' 'libxkbfile' 'gconf' 'libsodium' 'libxss' 'gtk2' 'nodejs' 'npm' 'alsa-lib' 'nss')
+options=(!strip)
+source=(
+"https://github.com/ssbc/${_upstream}/archive/v${pkgver}.tar.gz"
+'run.sh'
+"${pkgname}.desktop"
+)
+md5sums=('2d2b63a975486947d147e681429db749'
+ '26bbb4043ff690355e9d83f539484644'
+ '2b507044b1ae8f5d00aea5b148ec65f0')
+
+build() {
+ cd "${srcdir}/${_upstream}-${pkgver}"
+ npm install
+}
+
+package() {
+ cd "${srcdir}/${_upstream}-${pkgver}"
+ install -d "${pkgdir}/opt/${pkgname}"
+ cp -a * "${pkgdir}/opt/${pkgname}"
+ install -D assets/icon.png "${pkgdir}/usr/share/icons/hicolor/512x512/apps/${pkgname}.png"
+
+ cd "${srcdir}"
+ install -D run.sh "${pkgdir}/usr/bin/${pkgname}"
+ install -D "${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+}
diff --git a/run.sh b/run.sh
new file mode 100755
index 000000000000..3e4e22fd73ae
--- /dev/null
+++ b/run.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+cd /opt/ssb-patchwork
+./node_modules/.bin/electron index.js
diff --git a/ssb-patchwork.desktop b/ssb-patchwork.desktop
new file mode 100644
index 000000000000..00f1231ac3e5
--- /dev/null
+++ b/ssb-patchwork.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Name=Patchwork
+Comment=A decentralized messaging and sharing app built on top of Secure Scuttlebutt (SSB)
+Exec=ssb-patchwork
+Icon=ssb-patchwork
+Terminal=false
+StartupNotify=false
+Categories=Application;