summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b72f01a0181
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Apr 26 02:39:51 UTC 2019
+pkgbase = ssb-server
+ pkgdesc = The gossip and replication server for Secure Scuttlebutt - a distributed social network
+ pkgver = 14.1.12
+ pkgrel = 1
+ url = https://scuttlebut.io
+ arch = any
+ license = MIT
+ depends = nodejs
+ depends = npm
+ options = !strip
+ source = https://github.com/ssbc/ssb-server/archive/v14.1.12.tar.gz
+ sha256sums = 9e3fbf6c1f291780a45b14a16462cef14a487bee0fe646a8893782fae5321bb5
+
+pkgname = ssb-server
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..5ac2a18f23b2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.tar.gz
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47bea29754b6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: redfish <redfish@galactica.pw>
+
+pkgname=ssb-server
+pkgver=14.1.12
+pkgrel=1
+pkgdesc="The gossip and replication server for Secure Scuttlebutt - a distributed social network"
+arch=(any)
+url="https://scuttlebut.io"
+license=('MIT')
+depends=('nodejs' 'npm')
+source=(https://github.com/ssbc/ssb-server/archive/v$pkgver.tar.gz)
+
+options=(!strip)
+
+package(){
+ npm install -g --user root --prefix "${pkgdir}/usr" "$srcdir/v${pkgver}.tar.gz"
+}
+
+sha256sums=('9e3fbf6c1f291780a45b14a16462cef14a487bee0fe646a8893782fae5321bb5')