summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--g++-fix-3.patch12
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a657761d4a1d..4a146b936a05 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sseqplayer-git
pkgdesc = Library for decoding Nitro Composer Sound Format (NSCF) files
- pkgver = r32.a865efb
+ pkgver = r33.918c25c
pkgrel = 1
url = https://bitbucket.org/losnoco/sseqplayer
arch = i686
@@ -13,10 +13,12 @@ pkgbase = sseqplayer-git
source = makefile.patch
source = g++-fix.patch
source = g++-fix-2.patch
+ source = g++-fix-3.patch
sha256sums = SKIP
sha256sums = 9459ce17453fb70b04ccac200e77259f8995fb22f8c4232473657e16f0563b78
sha256sums = db3afb40a04b8199e78636d309e279b2ec47bf0c81b6c3fdb859c405568fde68
sha256sums = 9151cea3ba73daec0eec2a1b4708a84a351f41aa2767cee642e097cb759cfef6
+ sha256sums = ec2a2a32e467895f82aff74b881e8139fbf0e3dcd96b2c3f179c476fcc69313a
pkgname = sseqplayer-git
diff --git a/PKGBUILD b/PKGBUILD
index 5e31121b9203..fe378adcfadf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=sseqplayer-git
-pkgver=r32.a865efb
+pkgver=r33.918c25c
pkgrel=1
pkgdesc="Library for decoding Nitro Composer Sound Format (NSCF) files"
arch=(i686 x86_64)
@@ -10,11 +10,13 @@ makedepends=(git)
source=(${pkgname}::git+https://bitbucket.org/losnoco/sseqplayer.git
makefile.patch
g++-fix.patch
- g++-fix-2.patch)
+ g++-fix-2.patch
+ g++-fix-3.patch)
sha256sums=('SKIP'
'9459ce17453fb70b04ccac200e77259f8995fb22f8c4232473657e16f0563b78'
'db3afb40a04b8199e78636d309e279b2ec47bf0c81b6c3fdb859c405568fde68'
- '9151cea3ba73daec0eec2a1b4708a84a351f41aa2767cee642e097cb759cfef6')
+ '9151cea3ba73daec0eec2a1b4708a84a351f41aa2767cee642e097cb759cfef6'
+ 'ec2a2a32e467895f82aff74b881e8139fbf0e3dcd96b2c3f179c476fcc69313a')
pkgver() {
cd "$srcdir/$pkgname"
@@ -29,6 +31,7 @@ prepare() {
patch Makefile "$srcdir"/makefile.patch
patch Player.cpp "$srcdir"/g++-fix.patch
patch convert.h "$srcdir"/g++-fix-2.patch
+ patch common.h "$srcdir"/g++-fix-3.patch
}
diff --git a/g++-fix-3.patch b/g++-fix-3.patch
new file mode 100644
index 000000000000..2a1442d0f89a
--- /dev/null
+++ b/g++-fix-3.patch
@@ -0,0 +1,12 @@
+diff --git common.h common.h
+index 7470006..307c317 100644
+--- common.h
++++ common.h
+@@ -10,6 +10,7 @@
+
+ #pragma once
+
++#include <stdexcept>
+ #include <string>
+ #include <vector>
+ #include <cstring>