summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD38
2 files changed, 26 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6846eee994ee..7c15ab990e6c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = ssh-tools
pkgdesc = collection of various tools using ssh
- pkgver = 1.6
+ pkgver = 1.7
pkgrel = 1
- url = https://github.com/vaporup/ssh-tools/
+ url = https://github.com/vaporup/ssh-tools
arch = any
license = GPL
makedepends = help2man
- depends = openssh
+ depends = openssh-client
optdepends = colordiff: colors for ssh-diff
- source = https://github.com/vaporup/ssh-tools/archive/v1.6.tar.gz
- md5sums = ffbbf1c4174991644bd34c062ce92143
+ source = https://github.com/vaporup/ssh-tools/archive/v1.7.tar.gz
+ md5sums = da60a5c1925f17743585d7cb1167f9ef
pkgname = ssh-tools
-
diff --git a/PKGBUILD b/PKGBUILD
index 7106ba55863f..7c6c00eedf23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,44 @@
# Maintainer: Sven Wick <sven.wick@gmx.de>
pkgname=ssh-tools
-pkgver=1.6
+pkgver=1.7
pkgrel=1
pkgdesc="collection of various tools using ssh"
arch=("any")
-url="https://github.com/vaporup/ssh-tools/"
+url="https://github.com/vaporup/ssh-tools"
license=("GPL")
depends=("openssh")
optdepends=("colordiff: colors for ssh-diff")
makedepends=("help2man")
changelog=
source=("https://github.com/vaporup/${pkgname}/archive/v${pkgver}.tar.gz")
-md5sums=("ffbbf1c4174991644bd34c062ce92143")
+md5sums=("da60a5c1925f17743585d7cb1167f9ef")
build() {
- cd "$pkgname-$pkgver"
- mkdir -p "man"
+ cd "$pkgname-$pkgver"
- help2man -n "check if host is reachable using ssh_config" -S SSH-TOOLS -N --version-string " " -o man/ssh-ping.1 ./ssh-ping
- help2man -n "shows version of the SSH server you are connecting to" -S SSH-TOOLS -N --version-string " " -o man/ssh-version.1 ./ssh-version
- help2man -n "diff a file over SSH" -S SSH-TOOLS -N --version-string " " -o man/ssh-diff.1 ./ssh-diff
- help2man -n "get some facts about the remote system" -S SSH-TOOLS -N --version-string " " -o man/ssh-facts.1 ./ssh-facts
- help2man -n "prints server host keys in several formats" -S SSH-TOOLS -N --version-string " " -o man/ssh-hostkeys.1 ./ssh-hostkeys
- help2man -n "shows validity and information of SSH certificates" -S SSH-TOOLS -N --version-string " " -o man/ssh-certinfo.1 ./ssh-certinfo
- help2man -n "prints keys in several formats" -S SSH-TOOLS -N --version-string " " -o man/ssh-keyinfo.1 ./ssh-keyinfo
+ mkdir -p "man"
+
+ help2man -n "check if host is reachable using ssh_config" -S SSH-TOOLS -N --version-string " " -o man/ssh-ping.1 ./ssh-ping
+ help2man -n "shows version of the SSH server you are connecting to" -S SSH-TOOLS -N --version-string " " -o man/ssh-version.1 ./ssh-version
+ help2man -n "diff a file over SSH" -S SSH-TOOLS -N --version-string " " -o man/ssh-diff.1 ./ssh-diff
+ help2man -n "get some facts about the remote system" -S SSH-TOOLS -N --version-string " " -o man/ssh-facts.1 ./ssh-facts
+ help2man -n "prints server host keys in several formats" -S SSH-TOOLS -N --version-string " " -o man/ssh-hostkeys.1 ./ssh-hostkeys
+ help2man -n "shows validity and information of SSH certificates" -S SSH-TOOLS -N --version-string " " -o man/ssh-certinfo.1 ./ssh-certinfo
+ help2man -n "prints keys in several formats" -S SSH-TOOLS -N --version-string " " -o man/ssh-keyinfo.1 ./ssh-keyinfo
+ help2man -n "enforces password authentication" -S SSH-TOOLS -N --version-string " " -o man/ssh-force-password.1 ./ssh-force-password
}
package() {
- cd "$pkgname-$pkgver"
- mkdir -p $pkgdir/usr/share/man/man1/
- cp man/* $pkgdir/usr/share/man/man1/
+ cd "$pkgname-$pkgver"
+
+ mkdir -p $pkgdir/usr/share/man/man1/
+ cp man/* $pkgdir/usr/share/man/man1/
+
+ mkdir -p $pkgdir/usr/bin/
+ cp ssh-* $pkgdir/usr/bin/
- mkdir -p $pkgdir/usr/bin/
- cp ssh-* $pkgdir/usr/bin/
}