summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--sshconf.install11
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1ad9514475d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = sshconf
+ pkgdesc = A graphical frontend to manage ssh configurations for different hosts
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = http://sourceforge.net/apps/trac/sshconf
+ install = sshconf.install
+ arch = any
+ license = GPL3
+ depends = desktop-file-utils
+ depends = kdebindings-python
+ depends = openssh
+ depends = python2
+ depends = qt
+ source = http://download.sourceforge.net/project/sshconf/sshconf_0.6.2.tar.gz
+ sha256sums = a1a2437212391237d1d3e60db934570791a3b117e9512287ecc8bc1d172993a2
+
+pkgname = sshconf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d647aa05eb6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=sshconf
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="A graphical frontend to manage ssh configurations for different hosts"
+arch=('any')
+url="http://sourceforge.net/apps/trac/sshconf"
+license=('GPL3')
+depends=('desktop-file-utils' 'kdebindings-python' 'openssh' 'python2' 'qt')
+install=$pkgname.install
+source=(http://download.sourceforge.net/project/$pkgname/${pkgname}_${pkgver}.tar.gz)
+sha256sums=('a1a2437212391237d1d3e60db934570791a3b117e9512287ecc8bc1d172993a2')
+
+build() {
+ cd ${srcdir}/$pkgname-$pkgver
+
+#Python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py install --root=${pkgdir}
+}
diff --git a/sshconf.install b/sshconf.install
new file mode 100644
index 000000000000..2eaa60550d51
--- /dev/null
+++ b/sshconf.install
@@ -0,0 +1,11 @@
+post_install() {
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}