summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89c832b98d85..1aab87dca5ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,8 +4,9 @@ pkgbase = sshesame-git
pkgrel = 2
url = https://github.com/jaksi/sshesame
arch = x86_64
- license = Apache-2.0
- makedepends = go
+ license = Apache
+ makedepends = go-pie
+ depends = glibc
source = git+https://github.com/jaksi/sshesame
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 8f729d75f3b5..4fd3f5b6efda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,9 @@ pkgrel=2
pkgdesc="A fake SSH server that lets everyone in and logs their activity"
arch=('x86_64')
url='https://github.com/jaksi/sshesame'
-license=('Apache-2.0')
-makedepends=('go')
+license=('Apache')
+depends=('glibc')
+makedepends=('go-pie')
source=("git+https://github.com/jaksi/sshesame")
md5sums=('SKIP')
@@ -34,5 +35,5 @@ build() {
package() {
cd "${srcdir}/sshesame"
install -Dm755 sshesame-bin "${pkgdir}/usr/bin/sshesame"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/sshesame/LICENSE"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file