summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD11
3 files changed, 11 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec2bcc423e2b..4dd61309b9b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = sshuttle-git
pkgdesc = Transparent proxy server that forwards all TCP packets over ssh
- pkgver = v0.73+51_ge433c59
+ pkgver = v1.0.5+5_g97c25e9
pkgrel = 1
url = https://github.com/sshuttle/sshuttle
arch = any
@@ -8,7 +8,8 @@ pkgbase = sshuttle-git
checkdepends = python-pytest-runner
checkdepends = python-mock
makedepends = git
- makedepends = pandoc
+ makedepends = python-sphinx
+ makedepends = python-setuptools_scm
depends = python-setuptools
depends = iptables
depends = openssh
diff --git a/.gitignore b/.gitignore
index 93f5d9f2777e..d6df696527f6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg/
src/
*.tar.gz
*.tar.xz
+sshuttle/
diff --git a/PKGBUILD b/PKGBUILD
index a04f8c92318a..8ecaa45e899c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
# Contributor: alphazo <alphazo@gmail.com>
+# Maintainer: Abbas Maheryar <abbasmaheryar@gmail.com>
# This version fetches and install master branch from Git repo (now using the same repo as [Community] version).
pkgname=sshuttle-git
_gitname=sshuttle
-pkgver=v0.73+51_ge433c59
+pkgver=v1.0.5+5_g97c25e9
#_commit=e433c599e40bc47c7b0e4d16934815c84b26eea8
pkgrel=1
pkgdesc='Transparent proxy server that forwards all TCP packets over ssh'
@@ -11,7 +12,7 @@ arch=('any')
url="https://github.com/sshuttle/sshuttle"
license=('GPL2')
depends=('python-setuptools' 'iptables' 'openssh' 'net-tools')
-makedepends=('git' 'pandoc')
+makedepends=('git' 'python-sphinx' 'python-setuptools_scm')
checkdepends=('python-pytest-runner' 'python-mock')
conflicts=('sshuttle')
backup=('etc/sshuttle/tunnel.conf' 'etc/sshuttle/prefixes.conf')
@@ -31,7 +32,8 @@ build() {
cd "$_gitname"
python setup.py build
- pandoc -s -r markdown -w man -o sshuttle.8 sshuttle/sshuttle.md
+ cd docs
+ make man
}
check() {
@@ -43,7 +45,8 @@ package() {
cd "$_gitname"
python setup.py install --root="$pkgdir" -O1
- install -Dm644 sshuttle.8 "$pkgdir/usr/share/man/man8/sshuttle.8"
+ #install -Dm644 sshuttle.8 "$pkgdir/usr/share/man/man8/sshuttle.8"
+ install -Dm644 docs/_build/man/sshuttle.1 "$pkgdir/usr/share/man/man1/sshuttle.1"
install -d "$pkgdir/etc/sshuttle"
install -m644 "$srcdir"/{tunnel.conf,prefixes.conf} "$pkgdir/etc/sshuttle"