summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD12
3 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ec2bcc423e2b..255e0a4e2357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Fri Apr 1 09:07:26 UTC 2016
pkgbase = sshuttle-git
pkgdesc = Transparent proxy server that forwards all TCP packets over ssh
- pkgver = v0.73+51_ge433c59
+ pkgver = v0.77.2+10_g6e15e69
pkgrel = 1
url = https://github.com/sshuttle/sshuttle
arch = any
@@ -8,7 +10,8 @@ pkgbase = sshuttle-git
checkdepends = python-pytest-runner
checkdepends = python-mock
makedepends = git
- makedepends = pandoc
+ makedepends = python-sphinx
+ makedepends = python-setuptools_scm
depends = python-setuptools
depends = iptables
depends = openssh
diff --git a/.gitignore b/.gitignore
index 93f5d9f2777e..d6df696527f6 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,3 +2,4 @@ pkg/
src/
*.tar.gz
*.tar.xz
+sshuttle/
diff --git a/PKGBUILD b/PKGBUILD
index a04f8c92318a..0cf2fb757f0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=sshuttle-git
_gitname=sshuttle
-pkgver=v0.73+51_ge433c59
+pkgver=v0.77.2+10_g6e15e69
#_commit=e433c599e40bc47c7b0e4d16934815c84b26eea8
pkgrel=1
pkgdesc='Transparent proxy server that forwards all TCP packets over ssh'
@@ -11,7 +11,7 @@ arch=('any')
url="https://github.com/sshuttle/sshuttle"
license=('GPL2')
depends=('python-setuptools' 'iptables' 'openssh' 'net-tools')
-makedepends=('git' 'pandoc')
+makedepends=('git' 'python-sphinx' 'python-setuptools_scm')
checkdepends=('python-pytest-runner' 'python-mock')
conflicts=('sshuttle')
backup=('etc/sshuttle/tunnel.conf' 'etc/sshuttle/prefixes.conf')
@@ -30,8 +30,9 @@ pkgver() {
build() {
cd "$_gitname"
python setup.py build
-
- pandoc -s -r markdown -w man -o sshuttle.8 sshuttle/sshuttle.md
+
+ cd docs
+ make man
}
check() {
@@ -43,7 +44,8 @@ package() {
cd "$_gitname"
python setup.py install --root="$pkgdir" -O1
- install -Dm644 sshuttle.8 "$pkgdir/usr/share/man/man8/sshuttle.8"
+ #install -Dm644 sshuttle.8 "$pkgdir/usr/share/man/man8/sshuttle.8"
+ install -Dm644 docs/_build/man/sshuttle.1 "$pkgdir/usr/share/man/man1/sshuttle.1"
install -d "$pkgdir/etc/sshuttle"
install -m644 "$srcdir"/{tunnel.conf,prefixes.conf} "$pkgdir/etc/sshuttle"