summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb4e4d50bcda..f143b8153f20 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
pkgbase = ssimulacra
pkgdesc = Structural SIMilarity Unveiling Local And Compression Related Artifacts
- pkgver = 0.1
- pkgrel = 2
+ pkgver = 0.2
+ pkgrel = 1
url = https://github.com/cloudinary/ssimulacra
arch = x86_64
license = Apache
- makedepends = vtk
+ makedepends = boost
depends = opencv2
- source = git+https://github.com/cloudinary/ssimulacra.git#commit=589fac281aa4a8ecfb9ce07ec2e6f6dd1e6eccbb
+ depends = boost-libs
+ source = git+https://github.com/cloudinary/ssimulacra.git#commit=4c92d4184a8917fecdecccb68a8231cdfbc24249
sha512sums = SKIP
pkgname = ssimulacra
diff --git a/PKGBUILD b/PKGBUILD
index bfbf234e181a..1d559bd8479c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: spider-mario <spidermario@free.fr>
pkgname=ssimulacra
-pkgver=0.1
-pkgrel=2
+pkgver=0.2
+pkgrel=1
pkgdesc="Structural SIMilarity Unveiling Local And Compression Related Artifacts"
arch=('x86_64')
url="https://github.com/cloudinary/ssimulacra"
license=('Apache')
-depends=('opencv2')
-makedepends=('vtk')
-source=('git+https://github.com/cloudinary/ssimulacra.git#commit=589fac281aa4a8ecfb9ce07ec2e6f6dd1e6eccbb')
+depends=('opencv2' 'boost-libs')
+makedepends=('boost')
+source=('git+https://github.com/cloudinary/ssimulacra.git#commit=4c92d4184a8917fecdecccb68a8231cdfbc24249')
sha512sums=('SKIP')
prepare() {
cd "$pkgname"
- perl -pe 's/(?:C|LD)FLAGS\K=/+=/g' -i Makefile
+ perl -pe 's/(?:C|LD)FLAGS\K=/+=/g; s/ -lopencv_imgcodecs//' -i Makefile
}
build() {