summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..023737842f3c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ssimulacra
+ pkgdesc = Structural SIMilarity Unveiling Local And Compression Related Artifacts
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/cloudinary/ssimulacra
+ arch = x86_64
+ license = Apache
+ makedepends = vtk
+ depends = opencv
+ source = git+https://github.com/cloudinary/ssimulacra.git
+ sha512sums = SKIP
+
+pkgname = ssimulacra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93bfb7ea1306
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: spider-mario <spidermario@free.fr>
+pkgname=ssimulacra
+pkgver=0.1
+pkgrel=1
+pkgdesc="Structural SIMilarity Unveiling Local And Compression Related Artifacts"
+arch=('x86_64')
+url="https://github.com/cloudinary/ssimulacra"
+license=('Apache')
+depends=('opencv')
+makedepends=('vtk')
+source=('git+https://github.com/cloudinary/ssimulacra.git')
+sha512sums=('SKIP')
+
+prepare() {
+ cd "$pkgname"
+ perl -pe 's/(?:C|LD)FLAGS\K=/+=/g' -i Makefile
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 ssimulacra "$pkgdir"/usr/bin/ssimulacra
+}