summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD8
-rw-r--r--st-solarized-dark-0.8.1.diff75
2 files changed, 79 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3e8f02b1c45b..df0a9f32da04 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,11 +17,11 @@ epoch=1
# include config.h and any patches you want to have applied here
source=('git+https://git.suckless.org/st'
'https://st.suckless.org/patches/solarized/st-no_bold_colors-20170623-b331da5.diff'
-'https://st.suckless.org/patches/solarized/st-solarized-dark-20170623-b331da5.diff'
+'st-solarized-dark-0.8.1.diff'
)
-sha1sums=('SKIP'
-'SKIP'
-'SKIP')
+sha256sums=('SKIP'
+'71e1211189d9e11da93ee49388379c5f8469fcd3e1f48bb4d791ddaf161f5845'
+'3f5f1a54a225795542ee1f75fa14e21adaa4debb3130e674430c87c55c07ebac')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
diff --git a/st-solarized-dark-0.8.1.diff b/st-solarized-dark-0.8.1.diff
new file mode 100644
index 000000000000..ec0ebda7815c
--- /dev/null
+++ b/st-solarized-dark-0.8.1.diff
@@ -0,0 +1,75 @@
+From 0cc42d415cb16d1d40cb1462d19497fe1524a652 Mon Sep 17 00:00:00 2001
+From: grsakea <grsakea@users.noreply.github.com>
+Date: Tue, 27 Mar 2018 18:48:14 +0200
+Subject: [PATCH] Add solarized theme
+
+---
+ config.def.h | 45 +++++++++++++++++++++------------------------
+ 1 file changed, 21 insertions(+), 24 deletions(-)
+
+diff --git a/config.def.h b/config.def.h
+index 82b1b09..20a1a57 100644
+--- a/config.def.h
++++ b/config.def.h
+@@ -84,26 +84,23 @@ unsigned int tabspaces = 8;
+
+ /* Terminal colors (16 first used in escape sequence) */
+ static const char *colorname[] = {
+- /* 8 normal colors */
+- "black",
+- "red3",
+- "green3",
+- "yellow3",
+- "blue2",
+- "magenta3",
+- "cyan3",
+- "gray90",
+-
+- /* 8 bright colors */
+- "gray50",
+- "red",
+- "green",
+- "yellow",
+- "#5c5cff",
+- "magenta",
+- "cyan",
+- "white",
+-
++ /* solarized dark */
++ "#073642", /* 0: black */
++ "#dc322f", /* 1: red */
++ "#859900", /* 2: green */
++ "#b58900", /* 3: yellow */
++ "#268bd2", /* 4: blue */
++ "#d33682", /* 5: magenta */
++ "#2aa198", /* 6: cyan */
++ "#eee8d5", /* 7: white */
++ "#002b36", /* 8: brblack */
++ "#cb4b16", /* 9: brred */
++ "#586e75", /* 10: brgreen */
++ "#657b83", /* 11: bryellow */
++ "#839496", /* 12: brblue */
++ "#6c71c4", /* 13: brmagenta*/
++ "#93a1a1", /* 14: brcyan */
++ "#fdf6e3", /* 15: brwhite */
+ [255] = 0,
+
+ /* more colors can be added after 255 to use with DefaultXX */
+@@ -116,10 +113,10 @@ static const char *colorname[] = {
+ * Default colors (colorname index)
+ * foreground, background, cursor, reverse cursor
+ */
+-unsigned int defaultfg = 7;
+-unsigned int defaultbg = 0;
+-static unsigned int defaultcs = 256;
+-static unsigned int defaultrcs = 257;
++unsigned int defaultfg = 12;
++unsigned int defaultbg = 8;
++static unsigned int defaultcs = 14;
++static unsigned int defaultrcs = 15;
+
+ /*
+ * Default shape of cursor
+--
+2.16.3
+