summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92713c4d2e4e..e1995a4caa0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,6 +41,9 @@ prepare() {
sed '/@tic/d' -i Makefile
for file in "${source[@]}"; do
if [[ "$file" != *.diff ]]; then
+ # add config.h if present in source array
+ # Note: this supersedes the above sed to config.def.h
+ [[ "$file" == "config.h" ]] && cp "$SRCDEST/$file" .
continue
fi
# add all patches present in source array