summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD42
2 files changed, 61 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2372b0a03879
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = st-spcz-git
+ pkgdesc = Simple terminal emulator by suckless.org with mouse-scroll and alpha patches.
+ pkgver = 0.8.1.r0.g8936abb
+ pkgrel = 1
+ url = https://github.com/SirPatrickCZ/st
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = libxext
+ makedepends = ncurses
+ depends = libxft
+ optdepends = xorg-fonts-misc
+ conflicts = st
+ options = zipman
+ source = st::git+https://github.com/SirPatrickCZ/st.git#branch=master
+ md5sums = SKIP
+
+pkgname = st-spcz-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..394523f0e293
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: SirPatrickCZ Fiala456@gmail.com
+pkgname="st-spcz-git"
+_pkgname="st"
+pkgver=0.8.1.r0.g8936abb
+pkgrel=1
+pkgdesc="Simple terminal emulator by suckless.org with mouse-scroll and alpha patches."
+arch=('x86_64')
+url="https://github.com/SirPatrickCZ/st"
+license=('MIT')
+options=('zipman')
+depends=('libxft')
+makedepends=('git' 'libxext' 'ncurses')
+optdepends=('xorg-fonts-misc')
+conflicts=('st')
+source=("st::git+https://github.com/SirPatrickCZ/st.git#branch=master")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "${_pkgname}"
+ # skip terminfo which conflicts with nsurses
+ sed -i '/tic /,+1d' Makefile
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ make PREFIX=/usr DESTDIR="${pkgdir}" TERMINFO="$pkgdir/usr/share/terminfo" install
+} \ No newline at end of file