summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rw-r--r--config.h42
3 files changed, 31 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ee522666a885..8d3106606c84 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,8 @@
+# Generated by mksrcinfo v8
+# Thu Dec 17 18:00:36 UTC 2015
pkgbase = st-white-git
pkgdesc = A simple virtual terminal emulator for X.
- pkgver = 0.6.r32.gbf8c71e
+ pkgver = 0.6.r54.g375b287
pkgrel = 1
url = http://st.suckless.org
arch = i686
@@ -15,7 +17,7 @@ pkgbase = st-white-git
source = st-white-git::git://git.suckless.org/st
source = config.h
md5sums = SKIP
- md5sums = c3cd89ac96406c7c5381a7d1eb65ede0
+ md5sums = 1f022b612297651c1f2f8464b41c513b
pkgname = st-white-git
diff --git a/PKGBUILD b/PKGBUILD
index 714881bb9e06..0c1302166dcc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=st-white-git
_pkgname=st
-pkgver=0.6.r32.gbf8c71e
+pkgver=0.6.r54.g375b287
pkgrel=1
pkgdesc='A simple virtual terminal emulator for X.'
@@ -17,7 +17,7 @@ makedepends=('ncurses' 'libxext' 'git')
source=("$pkgname::git://git.suckless.org/st"
'config.h')
md5sums=('SKIP'
- 'c3cd89ac96406c7c5381a7d1eb65ede0')
+ '1f022b612297651c1f2f8464b41c513b')
pkgver() {
cd $pkgname
diff --git a/config.h b/config.h
index b62f77152745..413081bbb01a 100644
--- a/config.h
+++ b/config.h
@@ -62,12 +62,11 @@ static unsigned int cursorthickness = 2;
*/
static int bellvolume = 0;
-/* TERM value */
+/* default TERM value */
static char termname[] = "st-256color";
static unsigned int tabspaces = 8;
-
/* Terminal colors (16 first used in escape sequence) */
static const char *colorname[] = {
/* 8 normal colors */
@@ -94,6 +93,7 @@ static const char *colorname[] = {
/* more colors can be added after 255 to use with DefaultXX */
"#cccccc",
+ "#555555",
"DodgerBlue2",
"HotPink2",
"orange1",
@@ -106,27 +106,27 @@ static const char *colorname[] = {
/*
* Default colors (colorname index)
- * foreground, background, cursor
+ * foreground, background, cursor, reverse cursor
*/
static unsigned int defaultfg = 0;
static unsigned int defaultbg = 15;
-static unsigned int defaultcs = 21;
+static unsigned int defaultcs = 258;
+static unsigned int defaultrcs = 259;
/*
* Default shape of cursor
- * 2: Block
- * 4: Underline
- * 6: IBeam
+ * 2: Block ("█")
+ * 4: Underline ("_")
+ * 6: Bar ("|")
+ * 7: Snowman ("☃")
*/
-
static unsigned int cursorshape = 2;
-
/*
* Default colour and shape of the mouse cursor
*/
static unsigned int mouseshape = XC_xterm;
-static unsigned int mousefg = 17;
+static unsigned int mousefg = 258;
static unsigned int mousebg = 15;
/*
@@ -134,12 +134,14 @@ static unsigned int mousebg = 15;
* will reverse too. Another logic would only make the simple feature too
* complex.
*/
-static unsigned int defaultitalic = 19;
-static unsigned int defaultunderline = 17;
+static unsigned int defaultitalic = 260;
+static unsigned int defaultunderline = 258;
-/* Internal mouse shortcuts. */
-/* Beware that overloading Button1 will disable the selection. */
-static Mousekey mshortcuts[] = {
+/*
+ * Internal mouse shortcuts.
+ * Beware that overloading Button1 will disable the selection.
+ */
+static MouseShortcut mshortcuts[] = {
/* button mask string */
{ Button4, XK_ANY_MOD, "\031" },
{ Button5, XK_ANY_MOD, "\005" },
@@ -201,11 +203,17 @@ static KeySym mappedkeys[] = { -1 };
*/
static uint ignoremod = Mod2Mask|XK_SWITCH_MOD;
-/* Override mouse-select while mask is active (when MODE_MOUSE is set).
+/*
+ * Override mouse-select while mask is active (when MODE_MOUSE is set).
* Note that if you want to use ShiftMask with selmasks, set this to an other
- * modifier, set to 0 to not use it. */
+ * modifier, set to 0 to not use it.
+ */
static uint forceselmod = ShiftMask;
+/*
+ * This is the huge key array which defines all compatibility to the Linux
+ * world. Please decide about changes wisely.
+ */
static Key key[] = {
/* keysym mask string appkey appcursor crlf */
{ XK_KP_Home, ShiftMask, "\033[2J", 0, -1, 0},