summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
-rw-r--r--libs.patch21
3 files changed, 43 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e16b996f85a6..688d5256e26f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stag-git
- pkgdesc = A public domain ncurses based audio file tagger
+ pkgdesc = Ncurses based audio file tagger
pkgver = v1.0.r1.g0a158e7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/smabie/stag
arch = i686
arch = x86_64
@@ -10,7 +10,9 @@ pkgbase = stag-git
depends = ncurses
depends = taglib
conflicts = stag
- source = git+https://github.com/smabie/stag
+ source = git+https://github.com/smabie/stag.git
+ source = libs.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = stag-git
diff --git a/PKGBUILD b/PKGBUILD
index 84c7732cc32d..d10a13d7d1e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,41 @@
-# Maintainer: MGislv <nocentinigabriele91@gmail.com>
+# Maintainer: MGislv <mgislv at ceppo.xyz>
# Contributor: mutantmonkey <aur@mutantmonkey.in>
pkgname=stag-git
pkgver=v1.0.r1.g0a158e7
-pkgrel=1
-pkgdesc="A public domain ncurses based audio file tagger"
+pkgrel=2
+pkgdesc='Ncurses based audio file tagger'
arch=('i686' 'x86_64')
-url="https://github.com/smabie/stag"
+url='https://github.com/smabie/stag'
license=('custom')
depends=('ncurses' 'taglib')
makedepends=('git')
conflicts=('stag')
-source=(git+https://github.com/smabie/stag)
-sha256sums=('SKIP')
+source=("git+$url.git"
+ 'libs.patch')
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
cd stag
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd stag
+ patch --forward --strip=1 --input="$srcdir"/libs.patch
+}
+
build() {
cd stag
sed -n '/Released into the public domain/p' README > LICENSE
- export CFLAGS="$CFLAGS -ansi -pedantic -Wall -D_DEFAULT_SOURCE"
- export LDFLAGS="${LDFLAGS/--as-needed,/} -L/usr/lib `taglib-config --libs` -ltag_c -lstdc++"
- export CPPFLAGS="-I/usr/include `taglib-config --cflags`"
+ export LDFLAGS="${LDFLAGS/--as-needed,/}"
make
}
package() {
cd stag
- install -Dm755 stag "$pkgdir"/usr/bin/stag
- install -Dm644 stag.1 "$pkgdir"/usr/share/man/man1/stag.1
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/stag/LICENSE
+ install -Dm755 stag "$pkgdir/usr/bin/stag"
+ install -Dm644 stag.1 "$pkgdir/usr/share/man/man1/stag.1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
diff --git a/libs.patch b/libs.patch
new file mode 100644
index 000000000000..ab58855e9386
--- /dev/null
+++ b/libs.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,14 +4,13 @@
+ # This file is public domain as declared by Sturm Mabie.
+ #
+
+-CC=gcc
++CC=cc
+ PROG=stag
+-CURSES=-lncurses -lmenu -lform
++CURSES=-lncurses -lmenu -lform
+ CURSESW=-lncursesw -lmenuw -lformw -D_CURSESW_WIDE
+ FILES=ui.c stag.c tagger.c strlcpy.c strlcat.c basename.c dirname.c kb.c
+-CFLAGS+=-ansi -pedantic -Wall -D_BSD_SOURCE
+-CPPFLAGS+=-I/usr/local/include `taglib-config --cflags`
+-LDFLAGS+=-L/usr/local/lib `taglib-config --libs` -ltag_c -lstdc++
++CPPFLAGS+=-I/usr/include `taglib-config --cflags`
++LDFLAGS+=-L/usr/lib `taglib-config --libs` -ltag_c -lstdc++
+
+ wide:
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(CURSESW) $(FILES) -o $(PROG)