summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD47
-rw-r--r--libs.patch21
3 files changed, 55 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d6a11ff30ba..688d5256e26f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
pkgbase = stag-git
- pkgdesc = A C curses based mp3/ogg/flac tagging application (git version)
- pkgver = 93.0a158e7
- pkgrel = 1
- url = http://cryptm.org/~sturm/stag.html
+ pkgdesc = Ncurses based audio file tagger
+ pkgver = v1.0.r1.g0a158e7
+ pkgrel = 2
+ url = https://github.com/smabie/stag
arch = i686
arch = x86_64
- license = custom:none
+ license = custom
makedepends = git
depends = ncurses
depends = taglib
- provides = stag
conflicts = stag
- options = !buildflags
source = git+https://github.com/smabie/stag.git
+ source = libs.patch
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = stag-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f2219f7a8755..d10a13d7d1e4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,41 @@
-# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+# Maintainer: MGislv <mgislv at ceppo.xyz>
+# Contributor: mutantmonkey <aur@mutantmonkey.in>
+
pkgname=stag-git
-_gitname=stag
-pkgver=93.0a158e7
-pkgrel=1
-pkgdesc="A C curses based mp3/ogg/flac tagging application (git version)"
+pkgver=v1.0.r1.g0a158e7
+pkgrel=2
+pkgdesc='Ncurses based audio file tagger'
arch=('i686' 'x86_64')
-url="http://cryptm.org/~sturm/stag.html"
-license=('custom:none')
+url='https://github.com/smabie/stag'
+license=('custom')
depends=('ncurses' 'taglib')
makedepends=('git')
-options=('!buildflags')
-provides=('stag')
conflicts=('stag')
-source=('git+https://github.com/smabie/stag.git')
-sha256sums=('SKIP')
+source=("git+$url.git"
+ 'libs.patch')
+sha256sums=('SKIP'
+ 'SKIP')
pkgver() {
- cd $_gitname
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd stag
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd stag
+ patch --forward --strip=1 --input="$srcdir"/libs.patch
}
build() {
- cd $_gitname
- make
+ cd stag
+ sed -n '/Released into the public domain/p' README > LICENSE
+ export LDFLAGS="${LDFLAGS/--as-needed,/}"
+ make
}
package() {
- cd $_gitname
- install -Dm 755 stag $pkgdir/usr/bin/stag
- install -D stag.1 $pkgdir/usr/share/man/man1/stag.1
+ cd stag
+ install -Dm755 stag "$pkgdir/usr/bin/stag"
+ install -Dm644 stag.1 "$pkgdir/usr/share/man/man1/stag.1"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
-
-# vim:set ts=2 sw=2 et:
diff --git a/libs.patch b/libs.patch
new file mode 100644
index 000000000000..ab58855e9386
--- /dev/null
+++ b/libs.patch
@@ -0,0 +1,21 @@
+--- a/Makefile
++++ b/Makefile
+@@ -4,14 +4,13 @@
+ # This file is public domain as declared by Sturm Mabie.
+ #
+
+-CC=gcc
++CC=cc
+ PROG=stag
+-CURSES=-lncurses -lmenu -lform
++CURSES=-lncurses -lmenu -lform
+ CURSESW=-lncursesw -lmenuw -lformw -D_CURSESW_WIDE
+ FILES=ui.c stag.c tagger.c strlcpy.c strlcat.c basename.c dirname.c kb.c
+-CFLAGS+=-ansi -pedantic -Wall -D_BSD_SOURCE
+-CPPFLAGS+=-I/usr/local/include `taglib-config --cflags`
+-LDFLAGS+=-L/usr/local/lib `taglib-config --libs` -ltag_c -lstdc++
++CPPFLAGS+=-I/usr/include `taglib-config --cflags`
++LDFLAGS+=-L/usr/lib `taglib-config --libs` -ltag_c -lstdc++
+
+ wide:
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) $(CURSESW) $(FILES) -o $(PROG)