summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD38
2 files changed, 25 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8d6a11ff30ba..e16b996f85a6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
pkgbase = stag-git
- pkgdesc = A C curses based mp3/ogg/flac tagging application (git version)
- pkgver = 93.0a158e7
+ pkgdesc = A public domain ncurses based audio file tagger
+ pkgver = v1.0.r1.g0a158e7
pkgrel = 1
- url = http://cryptm.org/~sturm/stag.html
+ url = https://github.com/smabie/stag
arch = i686
arch = x86_64
- license = custom:none
+ license = custom
makedepends = git
depends = ncurses
depends = taglib
- provides = stag
conflicts = stag
- options = !buildflags
- source = git+https://github.com/smabie/stag.git
+ source = git+https://github.com/smabie/stag
sha256sums = SKIP
pkgname = stag-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f2219f7a8755..84c7732cc32d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,36 @@
-# Maintainer: mutantmonkey <aur@mutantmonkey.in>
+# Maintainer: MGislv <nocentinigabriele91@gmail.com>
+# Contributor: mutantmonkey <aur@mutantmonkey.in>
+
pkgname=stag-git
-_gitname=stag
-pkgver=93.0a158e7
+pkgver=v1.0.r1.g0a158e7
pkgrel=1
-pkgdesc="A C curses based mp3/ogg/flac tagging application (git version)"
+pkgdesc="A public domain ncurses based audio file tagger"
arch=('i686' 'x86_64')
-url="http://cryptm.org/~sturm/stag.html"
-license=('custom:none')
+url="https://github.com/smabie/stag"
+license=('custom')
depends=('ncurses' 'taglib')
makedepends=('git')
-options=('!buildflags')
-provides=('stag')
conflicts=('stag')
-source=('git+https://github.com/smabie/stag.git')
+source=(git+https://github.com/smabie/stag)
sha256sums=('SKIP')
pkgver() {
- cd $_gitname
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd stag
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd $_gitname
- make
+ cd stag
+ sed -n '/Released into the public domain/p' README > LICENSE
+ export CFLAGS="$CFLAGS -ansi -pedantic -Wall -D_DEFAULT_SOURCE"
+ export LDFLAGS="${LDFLAGS/--as-needed,/} -L/usr/lib `taglib-config --libs` -ltag_c -lstdc++"
+ export CPPFLAGS="-I/usr/include `taglib-config --cflags`"
+ make
}
package() {
- cd $_gitname
- install -Dm 755 stag $pkgdir/usr/bin/stag
- install -D stag.1 $pkgdir/usr/share/man/man1/stag.1
+ cd stag
+ install -Dm755 stag "$pkgdir"/usr/bin/stag
+ install -Dm644 stag.1 "$pkgdir"/usr/share/man/man1/stag.1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/stag/LICENSE
}
-
-# vim:set ts=2 sw=2 et: