summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD17
2 files changed, 16 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7d94fc43fcee..88835af30a94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,21 @@
pkgbase = standardese-git
pkgdesc = A (work-in-progress) nextgen Doxygen for C++
- pkgver = 0.3.4.r0.g7d5325c
- pkgrel = 1
- url = https://github.com/foonathan/standardese
+ pkgver = 0.5.2.r9.gefbc112
+ pkgrel = 4
+ url = https://github.com/standardese/standardese
arch = i686
arch = x86_64
license = MIT
makedepends = git
makedepends = cmake
makedepends = boost>=1.55
+ makedepends = cmark
depends = clang>=3.7.1
depends = boost-libs>=1.55
- depends = cmark
+ depends = llvm
provides = standardese
conflicts = standardese
- conflicts = spdlog-git
- source = git+https://github.com/foonathan/standardese.git
+ source = git+https://github.com/standardese/standardese.git
md5sums = SKIP
pkgname = standardese-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 1e1ac05e979c..f36fee84d09e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Filipe Verri <filipeverri@gmail.com>
pkgname=standardese-git
-pkgver=0.3.4.r0.g7d5325c
-pkgrel=1
+pkgver=0.5.2.r11.g457b264
+pkgrel=5
pkgdesc="A (work-in-progress) nextgen Doxygen for C++"
arch=('i686' 'x86_64')
-url="https://github.com/foonathan/standardese"
+url="https://github.com/standardese/standardese"
license=('MIT')
-depends=('clang>=3.7.1' 'boost-libs>=1.55' 'cmark' 'llvm')
-makedepends=('git' 'cmake' 'boost>=1.55')
+depends=('clang>=3.7.1' 'boost-libs>=1.55' 'llvm')
+makedepends=('git' 'cmake' 'boost>=1.55' 'cmark')
provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" 'spdlog-git')
-source=('git+https://github.com/foonathan/standardese.git')
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/standardese/standardese.git')
md5sums=('SKIP')
pkgver() {
@@ -25,8 +25,11 @@ build() {
mkdir build
cd build
+ # Statically link dependencies
cmake \
+ -DBUILD_SHARED_LIBS=OFF \
-DSTANDARDESE_BUILD_TEST=OFF \
+ -DCMAKE_BUILD_TYPE=none \
-DCMAKE_INSTALL_PREFIX="$pkgdir/usr" \
-DLIBCLANG_INCLUDE_DIR="/usr/include/" \
-DLIBCLANG_SYSTEM_INCLUDE_DIR="$(find /usr/lib/clang/ -type d -name include)" \