summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD16
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7d43c18d547
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = stanmath
+ pkgdesc = reverse-mode automatic differentiation library
+ pkgver = 3.3.0
+ pkgrel = 1
+ url = https://mc-stan.org/
+ arch = any
+ license = BSD
+ depends = boost
+ depends = sundials
+ depends = tbb
+ depends = eigen
+ source = https://github.com/stan-dev/math/archive/v3.3.0.tar.gz
+ sha256sums = fb96629fd3e5e06f0ad4c03a774e54b045cc1dcfde5ff65b6f78f0f05772770a
+
+pkgname = stanmath
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..90f23b297594
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,16 @@
+pkgname=stanmath
+pkgver=3.3.0
+pkgrel=1
+pkgdesc="reverse-mode automatic differentiation library"
+license=('BSD')
+arch=('any')
+url="https://mc-stan.org/"
+depends=('boost' 'sundials' 'tbb' 'eigen')
+source=("https://github.com/stan-dev/math/archive/v${pkgver}.tar.gz")
+sha256sums=('fb96629fd3e5e06f0ad4c03a774e54b045cc1dcfde5ff65b6f78f0f05772770a')
+
+package() {
+ cd math-${pkgver}
+ install -d "$pkgdir"/include
+ cp -r stan "$pkgdir"/include
+}