summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
-rwxr-xr-xstart-stanza.sh3
3 files changed, 11 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0c87a52dba03..2e6757852bd4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,16 @@
# Generated by mksrcinfo v8
-# Mon Oct 2 08:17:03 UTC 2017
+# Mon Feb 19 18:54:02 UTC 2018
pkgbase = stanza
pkgdesc = The reference compiler for Stanza, a high-level multi-paradigm optionally-typed programming language.
- pkgver = 0.11.7
- pkgrel = 2
+ pkgver = 0.12.8
+ pkgrel = 1
url = http://lbstanza.org/
install = install
arch = x86_64
license = GPL
- depends = gcc5
- noextract = lstanza_0_11_7.zip
- source = http://lbstanza.org/resources/stanza/lstanza_0_11_7.zip
- source = start-stanza.sh
- sha256sums = 87f59bf4ad42c76bee7b141fc860c79ee39890acbcf46effec58cb0a17350ffb
- sha256sums = 0439b9637691d406cec99e74d22c7899e4368954c99746b35a21fbc5f98dbe21
+ noextract = lstanza_0_12_8.zip
+ source = http://lbstanza.org/resources/stanza/lstanza_0_12_8.zip
+ sha256sums = 09d10c3a7271f101df1cbaf0f4c09ca5a31f1e9fe43fcc141174f7463c4f4bdd
pkgname = stanza
diff --git a/PKGBUILD b/PKGBUILD
index 805d6ff02224..1ffd8f53dd93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Eric Toombs <ee double you toombs at you waterloo dot see eh?>
pkgname='stanza'
-pkgver='0.11.7'
-pkgrel=2
+pkgver='0.12.8'
+pkgrel=1
pkgdesc='The reference compiler for Stanza, a high-level multi-paradigm optionally-typed programming language.'
arch=('x86_64')
groups=()
@@ -10,7 +10,6 @@ url='http://lbstanza.org/'
license=('GPL')
depends=(
- 'gcc5'
)
makedepends=(
)
@@ -21,14 +20,12 @@ provides=(
conflicts=(
)
-_srcfile='lstanza_0_11_7.zip'
+_srcfile="lstanza_${pkgver//./_}.zip"
source=(
"http://lbstanza.org/resources/stanza/$_srcfile"
- 'start-stanza.sh'
)
noextract=("$_srcfile") # Don't extract. Archive is weird. See prepare().
-sha256sums=('87f59bf4ad42c76bee7b141fc860c79ee39890acbcf46effec58cb0a17350ffb'
- '0439b9637691d406cec99e74d22c7899e4368954c99746b35a21fbc5f98dbe21')
+sha256sums=('09d10c3a7271f101df1cbaf0f4c09ca5a31f1e9fe43fcc141174f7463c4f4bdd')
install='install'
@@ -43,16 +40,8 @@ prepare() {
bsdtar xf "$srcdir/$_srcfile"
}
-#build() {
-#}
-
package() {
mkdir "$pkgdir/opt"
cp -pr "$srcdir/$pkgname" "$pkgdir/opt"
-
- install -D "$srcdir/start-stanza.sh" "$pkgdir/usr/bin/stanza"
-
- # For redirecting stanza from gcc 7 to gcc 5.
- mkdir "$pkgdir/opt/stanza/bin"
- ln -s "/usr/bin/gcc-5" "$pkgdir/opt/stanza/bin/cc"
+ ln -s "/opt/stanza/stanza" "$pkgdir/usr/bin/stanza"
}
diff --git a/start-stanza.sh b/start-stanza.sh
deleted file mode 100755
index 04e3f9e85b2c..000000000000
--- a/start-stanza.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/bash
-
-PATH="/opt/stanza/bin:$PATH" exec /opt/stanza/stanza "$@"