summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
-rw-r--r--install25
3 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6c695fa72a6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by mksrcinfo v8
+# Sat Sep 30 07:05:51 UTC 2017
+pkgbase = stanza
+ pkgdesc = The reference compiler for Stanza, a high-level multi-paradigm optionally typed programming language.
+ pkgver = 0.11.7
+ pkgrel = 1
+ url = http://lbstanza.org/
+ install = install
+ arch = x86_64
+ license = GPL
+ noextract = lstanza_0_11_7.zip
+ source = http://lbstanza.org/resources/stanza/lstanza_0_11_7.zip
+ sha256sums = 87f59bf4ad42c76bee7b141fc860c79ee39890acbcf46effec58cb0a17350ffb
+
+pkgname = stanza
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73155bf2e279
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Maintainer: Eric Toombs <ee double you toombs at you waterloo dot see eh?>
+
+pkgname='stanza'
+pkgver='0.11.7'
+pkgrel=1
+pkgdesc='The reference compiler for Stanza, a high-level multi-paradigm optionally typed programming language.'
+arch=('x86_64')
+groups=()
+url='http://lbstanza.org/'
+license=('GPL')
+
+depends=(
+)
+makedepends=(
+)
+optdepends=(
+)
+provides=(
+)
+conflicts=(
+)
+
+_srcfile='lstanza_0_11_7.zip'
+source=(
+ "http://lbstanza.org/resources/stanza/$_srcfile"
+)
+noextract=("$_srcfile")
+sha256sums=('87f59bf4ad42c76bee7b141fc860c79ee39890acbcf46effec58cb0a17350ffb')
+
+install='install'
+
+prepare() {
+ if [[ -d "$pkgname" ]]; then
+ rm -r "$pkgname"
+ fi
+ mkdir "$pkgname"
+ cd "$pkgname"
+ bsdtar xf "$srcdir/$_srcfile"
+}
+
+#build() {
+#}
+
+package() {
+ mkdir "$pkgdir/opt"
+ cp -pr "$srcdir/$pkgname" "$pkgdir/opt"
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/$pkgname/stanza" "$pkgdir/usr/bin/stanza"
+}
diff --git a/install b/install
new file mode 100644
index 000000000000..29fc8a2e4c06
--- /dev/null
+++ b/install
@@ -0,0 +1,25 @@
+#!/bin/bash
+
+message='NOTE: If stanza fails with the error message
+
+ Could not locate .stanza configuration file.
+
+then run the command (NOT AS ROOT!)
+
+ $ cd /opt/stanza && stanza install -platform linux
+
+to generate ~/.stanza. The command must be run with current directory
+/opt/stanza, or else it will fail with the error message
+
+ Could not determine Stanza installation directory.'
+
+# arg 1: the new package version
+post_install() {
+ echo "$message"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo "$message"
+}