summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 01cc23bf2c86..46bee5ebfe31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = statifier
pkgdesc = Create portable, self-containing Linux executables: Creates from dynamically linked executables and all it's libraries one file. Note: Does not play well with VDSO, which most modern kernels have activated.
pkgver = 1.7.4
- pkgrel = 4
+ pkgrel = 5
url = http://statifier.sourceforge.net/
arch = i386
arch = i486
@@ -9,6 +9,7 @@ pkgbase = statifier
arch = i686
arch = x86_64
license = GPL2
+ depends = bash
depends = gcc-libs
depends = glibc
source = statifier-1.7.4.tar.gz::https://sourceforge.net/projects/statifier/files/statifier/1.7.4/statifier-1.7.4.tar.gz/download
@@ -17,4 +18,3 @@ pkgbase = statifier
depends_x86_64 = lib32-glibc
pkgname = statifier
-
diff --git a/PKGBUILD b/PKGBUILD
index 63593c71f000..7e0c4b59858f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@ pkgname="${_pkgname}"
_pkgver=1.7.4
# epoch=0
pkgver="${_pkgver}"
-pkgrel=4
+pkgrel=5
pkgdesc="Create portable, self-containing Linux executables: Creates from dynamically linked executables and all it's libraries one file. Note: Does not play well with VDSO, which most modern kernels have activated."
arch=('i386' 'i486' 'i586' 'i686' 'x86_64')
url="http://statifier.sourceforge.net/"
license=('GPL2')
depends=(
+ 'bash'
'gcc-libs'
'glibc'
)
@@ -50,7 +51,7 @@ build() {
_unpackeddir="${srcdir}/${_pkgname}-${_pkgver}"
cd "${_unpackeddir}"
- make
+ make || make
}
package() {