summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD23
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c2039f349c0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = statnot
+ pkgdesc = Notification daemon for lightweight window managers
+ pkgver = 0.0.4
+ pkgrel = 3
+ url = http://github.com/halhen/statnot
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = pygtk
+ depends = python2-dbus
+ depends = python2-notify
+ optdepends = libnotify: send notifications to statnot
+ optdepends = xorg-xsetroot: default configuration calls xsetroot
+ source = https://github.com/halhen/statnot/archive/0.0.4.tar.gz
+ md5sums = 73b74044b7aec19ab2483d5bac04eb8e
+
+pkgname = statnot
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dee8bfb0fd3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: halhen <halhen at k2h dot se>
+
+pkgname=statnot
+pkgver=0.0.4
+pkgrel=3
+pkgdesc="Notification daemon for lightweight window managers"
+arch=('i686' 'x86_64')
+url="http://github.com/halhen/statnot"
+license=('GPL')
+depends=('pygtk' 'python2-dbus' 'python2-notify')
+optdepends=(
+ 'libnotify: send notifications to statnot'
+ 'xorg-xsetroot: default configuration calls xsetroot')
+source=(https://github.com/halhen/$pkgname/archive/$pkgver.tar.gz)
+md5sums=('73b74044b7aec19ab2483d5bac04eb8e')
+
+package() {
+ cd $pkgname-$pkgver
+ sed -i '1 s/python$/python2/' statnot
+ make DESTDIR="$pkgdir" install
+}
+