summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f5b804602a62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = status
+ pkgdesc = Simple status thing for using with i3
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/sandsmark/status
+ arch = x86_64
+ arch = i686
+ license = GPL2
+ makedepends = gcc
+ depends = libpulse
+ source = https://github.com/sandsmark/status/archive/1.tar.gz
+ sha256sums = 496d996053193984f44bc8d183afa17422abf10d7a83da8dba819564fb835c72
+
+pkgname = status
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d257433adc2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname=status
+pkgver=1
+pkgrel=1
+pkgdesc='Simple status thing for using with i3'
+url='https://github.com/sandsmark/status'
+arch=('x86_64' 'i686')
+license=('GPL2')
+makedepends=(gcc)
+depends=('libpulse')
+source=("https://github.com/sandsmark/status/archive/${pkgver}.tar.gz")
+sha256sums=('496d996053193984f44bc8d183afa17422abf10d7a83da8dba819564fb835c72')
+
+build() {
+ cd status-${pkgver}
+ make
+}
+
+package() {
+ cd status-${pkgver}
+ install -D -m755 status -t "${pkgdir}/usr/bin"
+}