summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de668e6ab99d..b9ef749737e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,12 @@
pkgbase = steamtinkerlaunch
pkgdesc = Wrapper script for Steam custom launch options
- pkgver = 1.6.6
+ pkgver = 2.0.0
pkgrel = 1
url = https://github.com/frostworx/steamtinkerlaunch
arch = any
license = GPL3
depends = bash
+ depends = yad
optdepends = strace: write a strace log of the launched game
optdepends = gamemode: for using GameMode per game
optdepends = mangohud: for using MangoHUD per game
@@ -26,8 +27,9 @@ pkgbase = steamtinkerlaunch
optdepends = wine: for optional Vortex Mod Manager support
optdepends = gameconqueror: for optional cheating
optdepends = xorg-xprop: for optional window toggle and side-by-side VR
- source = steamtinkerlaunch-1.6.6.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v1.6.6.tar.gz
- sha256sums = 7dd1678159c23568223cf2a35c393a3c5d98cb3a0887c740e52c65ec46d4bfe4
+ optdepends = gamescope: for optional GameScope support
+ source = steamtinkerlaunch-2.0.0.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.0.0.tar.gz
+ sha256sums = e618a63b68d1a354d65a765b3eefbabb3127abb7cd97822a18a079da06a9d02d
pkgname = steamtinkerlaunch
diff --git a/PKGBUILD b/PKGBUILD
index 549c628615d3..b4ee57400b14 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,16 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=steamtinkerlaunch
-pkgver=1.6.6
+pkgver=2.0.0
pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
-depends=('bash')
+depends=(
+ 'bash'
+ 'yad'
+)
optdepends=(
'strace: write a strace log of the launched game'
'gamemode: for using GameMode per game'
@@ -30,17 +33,18 @@ optdepends=(
'wine: for optional Vortex Mod Manager support'
'gameconqueror: for optional cheating'
'xorg-xprop: for optional window toggle and side-by-side VR'
+ 'gamescope: for optional GameScope support'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('7dd1678159c23568223cf2a35c393a3c5d98cb3a0887c740e52c65ec46d4bfe4')
+sha256sums=('e618a63b68d1a354d65a765b3eefbabb3127abb7cd97822a18a079da06a9d02d')
package() {
cd "$srcdir/$pkgname-${pkgver}"
install -Dm755 stl -t "$pkgdir/usr/bin"
install -d "$pkgdir/usr/share/stl"
- cp -r categories regs tweaks "$pkgdir/usr/share/stl"
+ cp -r categories misc regs tweaks "$pkgdir/usr/share/stl"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}