summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c756d99425a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = stig-git
+ pkgdesc = TUI and CLI client for the Transmission daemon
+ pkgver = 0.1.0a.r2.9da7ec5
+ pkgrel = 1
+ url = https://github.com/rndusr/stig
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = python-urwid
+ depends = python-urwidtrees-git
+ depends = python-aiohttp
+ depends = python-appdirs
+ depends = python-blinker
+ provides = stig
+ conflicts = stig
+ source = git+https://github.com/rndusr/stig.git
+ sha256sums = SKIP
+
+pkgname = stig-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b46c59fdf55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Kazuo Teramoto <kaz.rag at gmail dot com>
+
+pkgbase=('stig-git')
+pkgname=('stig-git')
+pkgver=0.1.0a.r2.9da7ec5
+pkgrel=1
+pkgdesc="TUI and CLI client for the Transmission daemon"
+url="https://github.com/rndusr/stig"
+depends=('python' 'python-urwid' 'python-urwidtrees-git' 'python-aiohttp'
+ 'python-appdirs' 'python-blinker')
+makedepends=('git' 'python-setuptools')
+license=('GPL')
+arch=('any')
+provides=('stig')
+conflicts=('stig')
+source=("git+https://github.com/rndusr/stig.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd stig
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//')"
+}
+
+build() {
+ cd stig
+ python setup.py build
+}
+
+package() {
+ cd stig
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}