summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD11
2 files changed, 6 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e683add25ce7..2b097ec794eb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stig-git
pkgdesc = TUI and CLI client for the Transmission daemon
- pkgver = 0.11.2a0.r12.0d299a2c
- pkgrel = 3
+ pkgver = 0.11.2a0.r13.7d8b621d
+ pkgrel = 1
url = https://github.com/rndusr/stig
arch = any
license = GPL
@@ -14,6 +14,7 @@ pkgbase = stig-git
depends = python-pyxdg
depends = python-blinker
depends = python-natsort
+ depends = python-mock
optdepends = python-aiohttp-socks: proxy support
optdepends = python-pprofile: profiling
optdepends = python-setproctitle: prettifies the process name
diff --git a/PKGBUILD b/PKGBUILD
index e425c509ddfa..ad6031203cb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Kazuo Teramoto < kaz.rag [at] gmail [dot] com >
pkgname=stig-git
-pkgver=0.11.2a0.r12.0d299a2c
-pkgrel=3
+pkgver=0.11.2a0.r13.7d8b621d
+pkgrel=1
pkgdesc='TUI and CLI client for the Transmission daemon'
url='https://github.com/rndusr/stig'
depends=('python' 'python-urwid' 'python-urwidtrees' 'python-aiohttp'
- 'python-pyxdg' 'python-blinker' 'python-natsort')
+ 'python-pyxdg' 'python-blinker' 'python-natsort' 'python-mock')
makedepends=('git' 'python-setuptools')
optdepends=('python-aiohttp-socks: proxy support'
'python-pprofile: profiling'
@@ -26,11 +26,6 @@ pkgver() {
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g;s/^v//')"
}
-prepare(){
- cd stig
- sed -i 's/urwidtrees>=1.0.3dev0/urwidtrees>=1.0.2/' setup.py
-}
-
build() {
cd stig
python setup.py build